طراحی پلان شماره گیری استاتیک

پلن شماره گیری یک طرح شماره گذاری برای شبکه های دارای قابلیت صوتی است. این روشی است که فرد یا بلوک های شماره تلفن (آدرس E.164) را به خطوط یا مدارهای فیزیکی اختصاص می دهید. شبکه تلفن آمریکای شمالی بر اساس طرح شماره گیری 10 رقمی متشکل از کدهای منطقه 3 رقمی و شماره تلفن های 7 رقمی است. برای شماره‌های تلفنی که در یک کد منطقه قرار دارند، از یک طرح شماره‌گیری ۷ رقمی برای شبکه عمومی تلفن سوئیچ شده (PSTN) استفاده می‌شود. ویژگی های موجود در یک سوئیچ تلفن (مانند Centrex) از یک طرح شماره گیری سفارشی 5 رقمی برای مشتریان خاصی که مشترک آن سرویس هستند پشتیبانی می کند. سانترال ها از طرح های شماره گیری با طول متغیر نیز پشتیبانی می کنند که شامل 3 تا 11 رقم است.

طرح های شماره گیری در شبکه H.323 شامل الگوهای شماره گیری خاصی هستند تا کاربران بتوانند به یک شماره تلفن خاص دسترسی پیدا کنند. کدهای دسترسی، کدهای منطقه، کدهای تخصصی، و ترکیبی از اعداد شماره گیری شده، همه بخشی از هر طرح شماره گیری خاصی هستند. پلن های شماره گیری مورد استفاده با روترهای دارای قابلیت صوتی اساساً فرآیند تعیین اینکه کدام و چند رقم در هر یک از پیکربندی ها ذخیره شود را توصیف می کند. اگر ارقام شماره گیری شده با شماره و الگوها مطابقت داشته باشند، تماس برای ارسال پردازش می شود.

طراحی پلان شماره گیری نیاز به دانش توپولوژی شبکه، الگوهای شماره گیری فعلی شماره تلفن، مکان های پیشنهادی روتر و الزامات مسیریابی ترافیک دارد. هیچ پروتکل استانداردی برای مسیریابی پویا آدرس های تلفن E.164 تعریف نشده است. تا زمانی که یک پروتکل مسیریابی پویا مبتنی بر استاندارد برای آدرس‌های تلفن E.164 ایجاد شود، برنامه‌های شماره‌گیری VoIP H.323 به صورت ایستا پیکربندی و بر روی پلت‌فرم‌های دروازه و دروازه‌بان مدیریت می‌شوند.

اجزای اصلی شبکه های بزرگ H.323
زیرساخت یک شبکه VoIP معمولی H.323 شامل دروازه‌ها (GWs) و دروازه‌بان‌ها (GKs) است. در یک شبکه ارائه دهنده خدمات معمولی، تعدادی GW در نقاط حضور (POPs) در سراسر منطقه تحت پوشش ارائه دهنده خدمات مستقر می شوند. یک GK برای گروه بندی این GW ها در یک منطقه منطقی کنترل و انجام تمام مسیریابی تماس ها در بین آنها استفاده می شود.

شبکه های VoIP بزرگتر H.323 ممکن است از چندین GK تشکیل شده باشند که شبکه را به مناطق مختلف محلی تقسیم می کنند. در این حالت، GK ها باید با یکدیگر ارتباط برقرار کنند تا تماس های بین GW های واقع در مناطق مختلف را هدایت کنند. سیسکو برای ساده‌سازی مدیریت طرح شماره‌گیری برای این شبکه‌های چند دروازه‌بان، مفهوم دروازه‌بان دایرکتوری (DGK) را برای مدیریت مسیریابی تماس بین GK‌های محلی معرفی کرد. شکل 1 چگونگی ارتباط این اجزای اصلی شبکه H.323 را به یکدیگر نشان می دهد.

شکل 1 H.323 اجزای اصلی شبکه

جدول 1 عملکرد اجزای اصلی شبکه را خلاصه می کند.

جدول 1 اجزای اصلی و عملکرد آنها

Component Functions
Gateway
  • Acts as the interface between the PSTN and the IP network
  • Normalizes numbers from the PSTN before they enter the IP network
  • Normalizes numbers from the IP network before they enter the PSTN
  • Contains the dial peer configuration
  • Registers to a GK
Gatekeeper
  • Performs call routing searches at an intermediate level (for example, NPA-NXX)
  • Distributes the NPA among other GKs
  • Provides GW resource management (for example, RAI and gw-priority)
  • Provides zone maintenance
Directory Gatekeeper
  • Performs call routing searches at the highest level (for example, country code)
  • Distributes country codes among other DGKs
  • Forwards location requests (LRQs) to a partner DGK if the call does not terminate in the local service provider DGK

با توجه به طرح شماره گیری VoIP، هر جزء در شبکه H.323 مسئولیت خاصی دارد. GW ها تصمیمات مسیریابی لبه را بین PSTN و شبکه H.323 می گیرند. دروازه‌بان‌ها و دروازه‌بان‌های دایرکتوری منطق مسیریابی تماس اصلی را در میان دستگاه‌های درون شبکه H.323 مدیریت می‌کنند. این سند الزامات پیکربندی هر یک از این اجزای شبکه را توضیح می دهد. شکل 2 رابطه GW ها، GKs و DGK ها را در یک شبکه VoIP در مقیاس بزرگ H.323 نشان می دهد.

شکل 2 رابطه دروازه ها، دروازه بان ها و دروازه بان های دایرکتوری

هنگامی که یک تماس ارائه می شود، GW ها تعیین می کنند که آیا آن را به PSTN ارسال کنند یا به شبکه VoIP H.323. اگر تماس به شبکه VoIP H.323 ارسال شود، GW سپس از دروازه بان می خواهد که بهترین نقطه پایانی را برای دریافت تماس انتخاب کند. بر اساس جدول مسیریابی خود، دروازه‌بان ممکن است متوجه شود که این نقطه پایانی دستگاهی در منطقه کنترل محلی خودش است و آدرس IP نقطه پایانی را ارائه می‌کند. از طرف دیگر، ممکن است تعیین کند که نقطه پایانی تحت کنترل یک دروازه‌بان راه دور دیگر قرار دارد. در این حالت دوم، دروازه‌بان درخواست مکان (LRQ) را مستقیماً یا از طریق دروازه‌بان دایرکتوری به دروازه‌بان راه دور ارسال می‌کند. دروازه‌بان راه دور در نهایت با آدرس نقطه پایانی پاسخ می‌دهد.

ارتباط بین GW ها و GK ها بر اساس پیام های استاندارد ثبت، پذیرش و وضعیت (RAS) H.323v2 است. GWs از دروازه بانان برای مسیرها با استفاده از پیام های درخواست پذیرش RAS (ARQ) و تأیید پذیرش (ACF) پرس و جو می کند. دروازه‌بان‌های سیسکو و دروازه‌بان‌های دایرکتوری نیز با استفاده از RAS LRQ و پیام‌های تایید مکان (LCF) با یکدیگر ارتباط برقرار می‌کنند. پروتکل حمل و نقل بلادرنگ (RTP) توابع حمل و نقل انتها به انتها را فراهم می کند. شکل 3 نمونه ای از توالی پیام RAS را در زمانی که تلفن A با تلفن B تماس می گیرد نشان می دهد.

شکل 3 نمونه ای از پیام رسانی RAS هنگامی که تلفن A با تلفن B تماس می گیرد

نمای کلی طرح شماره گیری
طرح شماره گیری روشی است که توسط آن بلوک های جداگانه شماره تلفن (از لحاظ فنی، آدرس E.164) به امکانات فیزیکی یا مدار اختصاص داده می شود. برای شبکه های ارائه دهنده خدمات در مقیاس بزرگ، طرح های شماره گیری از عناصر زیر تشکیل شده است:

  • گروه بندی از پیشوندهای E.164 با توجه به مناطق و منطقه GKs
  • خصیص بلوک های آدرس E.164 به POP و POP GW
  • عادی سازی (ترجمه اعداد، پیشوند، و حذف رقم) شماره های تلفن در POP GWs
  • ایجاد POTS و VoIP شماره گیری همتا در GWs

همتاهای شماره گیری POTS شماره تلفن یا پیشوندهای دستگاه های تلفن متصل را تعیین می کنند و همتایان شماره گیری VoIP آدرس IP دستگاه راه دور (H.323 GW، GK یا نقطه پایانی) را که به شماره تلفن های راه دور متصل است، تعیین می کنند. همتاهای شماره گیری POTS همیشه به یک پورت صوتی روی روتر اشاره می کنند و مقصد شماره گیری همتای VoIP همیشه آدرس IP دستگاهی است که می تواند تماس VoIP را خاتمه دهد.

روش طراحی برای پلان های شماره گیری در مقیاس بزرگ
هنگام طراحی پلان شماره گیری در مقیاس بزرگ، استفاده از برخی اصول اولیه طراحی مهم است. گزینه های طراحی در این سند، اصول شرح داده شده در بخش های زیر را در نظر می گیرند:

  • توزیع طرح شماره گیری
  • طراحی سلسله مراتبی
  • سادگی در تهیه
  • کاهش تاخیر پس از شماره گیری
  • در دسترس بودن و تحمل خطا

Dial Plan Distribution
معماری پلان شماره گیری خوب به توزیع موثر منطق پلان شماره گیری بین اجزای GW و GK متکی است. جداسازی دستگاه‌های H.323 در بخش خاصی از پلان شماره‌گیری، پیچیدگی پیکربندی را کاهش می‌دهد. هر جزء می تواند بر انجام وظایف خاص تمرکز کند. به طور کلی، جزئیات مربوط به POP محلی در GW محلی انجام می شود. تصمیمات مسیریابی سطح بالاتر به GK ها و DGK ها منتقل می شوند. یک شبکه به خوبی طراحی شده، اکثر منطق طرح شماره گیری را در دستگاه های GK و DGK قرار می دهد.

طراحی سلسله مراتبی
سعی کنید اکثر منطق طرح شماره گیری (تصمیم گیری مسیریابی و شکست) را در بالاترین سطح مؤلفه نگه دارید. DGK به طور کلی دستگاه بالاترین سطح در نظر گرفته می شود. با حفظ یک طراحی سلسله مراتبی، اضافه کردن و حذف مناطق را قابل مدیریت تر می کنید. به عنوان مثال، زمانی که تغییرات پیکربندی به جای همه GK های ناحیه، فقط به یک DGK و یک منطقه GK منفرد انجام شود، مقیاس بندی کل شبکه بسیار آسان تر است.

با استفاده از GWs، GKs و DGKs از یک رویکرد معماری لایه‌ای استفاده کنید. امنیت، افزونگی و مدیریت شبکه پس از انجام مراحل زیر اجرا می شوند:

  1. مناطق تحت پوشش طرح شماره گیری خود را تعیین کنید. به عنوان مثال، یک GK (به جای DGK) می تواند یک کد کشور را پوشش دهد.
  2. تجزیه و تحلیل و گروه بندی منطقی مؤلفه ها برای تعیین اینکه هر مؤلفه مسئولیت کدام ناحیه (ها) را دارد: برای مثال یک کد کشور، یک کد منطقه، یا چند پیشوند.
  3. در سطح GW، به طور منطقی GW ها را به POP گروه بندی کنید. (به طور کلی، POP ها در مناطق تحت پوشش بالاترین تراکم قرار دارند: برای مثال شهرهای بزرگ.)
  4. با انجام کارهای زیر مشخص کنید که به چند دروازه نیاز دارید:
    1. ترافیک ساعت شلوغ (BHT) را اندازه گیری کنید. (شبکه را برای حجم ساعت اوج طراحی کنید.)
    2. تعداد DS-0هایی که برای کار با BHT نیاز دارید را تعیین کنید.
    3. تعیین کنید که برای سرویس دهی DS-0 به چند GW نیاز دارید.
    4. عملکرد تماس در ثانیه و ظرفیت DS-0 پلت فرم انتخابی GW را درک کنید.
  5. منطقاً POP ها را به مناطق جدا کنید. یک منطقه می تواند یک یا چند POP داشته باشد.
  6. در سطح GK، تعیین کنید که کدام GK باید کدام مناطق را اداره کند. یک GK برای گروه بندی GW ها در مناطق کنترل منطقی و انجام تمام مسیریابی تماس ها بین مناطق استفاده می شود.
    1. تعداد GKهایی که نیاز دارید به ظرفیت GW و بار ترافیک بستگی دارد. تعداد GK در هر POP یا POP در هر GK بستگی به تعداد GW استفاده شده دارد. به عنوان مثال، 35 گیگاوات در 1 POP می تواند 1 منطقه باشد که به یک GK نیاز دارد. 4 POP با 4 گیگاوات هر کدام ممکن است با یک GK که 16 گیگاوات را مدیریت می کند به اندازه کافی عمل کنند.
  7. در سطح DGK، تعیین کنید که کدام DGK باید کدام GK را اداره کند. مرحله 3 را ببینید.
  8. در نظر بگیرید که DGK های شما (کامپوننت بالاترین سطح شما) LRQ ها را با سایر DGK ها مبادله می کند و به عنوان نقطه ای بین حامل های جداگانه عمل می کند.

سادگی در تامین
هنگام طراحی شبکه باید پلان شماره گیری روی GW و GK را تا حد امکان ساده و متقارن نگه دارید. سعی کنید با استفاده از قوانین ترجمه برای دستکاری الگوهای شماره گیری رقمی محلی، برنامه های شماره گیری ثابتی را در GW ها حفظ کنید. این الگوهای اعداد را می توان قبل از ورود ارقام به هسته VoIP در قالب یا الگوی استاندارد عادی کرد. قرار دادن ارقام در قالب استاندارد، تهیه پیشوند منطقه GK و مدیریت همتا شماره گیری GW را ساده می کند.

این روش به کاهش تعداد تنظیمات همتای شماره گیری در رابط POTS خروجی کمک می کند. اگر می توان GK را برای هدایت فقط تماس های یک کد منطقه خاص به یک GW خاص تدارک دید، دیگر نیازی نیست که همه GW های منفرد را با کد منطقه مربوطه خود تهیه کنید. در عوض، ممکن است بتوانید تنظیمات GW را تعمیم دهید. با عادی سازی عدد، طول جستجوی پیشوند منطقه را نیز کاهش می دهید و زمان مورد نیاز برای جستجوی یک تطابق پیشوند منطقه را کاهش می دهید. به عنوان مثال، اگر الگوی رقمی 0118943xxxx دارید، می توانید عدد را به عنوان 8943xxxx ارسال کنید و جستجوی GK را در 89 در مقابل 01189 داشته باشید.

قوانین عادی سازی اعداد و ترجمه
تنظیمات پلان شماره گیری دروازه بر روی اطلاعات دسترسی به PSTN محلی برای لبه شبکه H.323 تمرکز دارد. این تنظیمات پلان شماره گیری شامل تعریف اینکه کدام پیشوندهای E.164 توسط اتصالات PSTN GW پشتیبانی می شوند، می باشد. در طرح‌های ارائه‌دهنده خدمات در مقیاس بزرگ، ممکن است برای انجام دستکاری رقم به GW تکیه کنید، به موجب آن GW یک شماره فراخوانی (یا فراخوانی شده) را می‌گیرد و قبل از ارسال شماره به مقصد، ارقام را حذف یا اضافه می‌کند (پیشوند). فرآیند قالب بندی عدد به یک الگوی از پیش تعریف شده، نرمال سازی اعداد نامیده می شود.

شکل 4 نمونه ای از عادی سازی اعداد از PSTN به هسته VoIP را نشان می دهد. دستکاری رقم را می توان در پورت POTS ورودی یا شماره گیری VoIP خروجی پیکربندی کرد تا یک الگوی 7، 10، 11 یا x رقمی را به یک الگوی 10 رقمی ثابت (مرکز ایالات متحده) قالب بندی کند. نتیجه عددی است که با ورود به فضای ابری VoIP عادی شده است.

شکل 4 عادی سازی اعداد از PSTN به VoIP

قوانین ترجمه
GW از قوانین ترجمه سیسکو IOS برای انجام دستکاری رقم استفاده می کند. قوانین ترجمه را می توان بر روی پورت فیزیکی GW یا در یک شماره گیری VoIP پیکربندی کرد، همانطور که در مثال زیر نشان داده شده است:

translation-rule 1
Rule 0 ^0111.% 1
Rule 1 ^0112.% 2
Rule 2 ^0113.% 3
Rule 3 ^0114.% 4
Rule 4 ^0115.% 5
Rule 5 ^0116.% 6
Rule 6 ^0117.% 7
Rule 7 ^0118.% 8
Rule 8 ^0119.% 9
!
dial-peer voice 1 voip
destination-pattern 011T
translate-outgoing called 1
session target ras
!

قانون ترجمه قبلی با الگوهای رقمی که از 0111 تا 0119 شروع می شوند مطابقت دارد و این الگوی 4 رقمی را به یک رقم از 1 تا 9 تبدیل می کند، در حالی که ارقام باقی مانده در الگوی رقمی را حفظ می کند. این فرآیند به طور موثر 011 (یک کد دسترسی بین‌المللی رایج) را از بین می‌برد و ارقام باقیمانده را برای مسیریابی تماس به دروازه‌بان VoIP ارسال می‌کند.

می‌توانید از قوانین ترجمه برای دستکاری شماره‌های شناسایی خودکار شماره (ANI) و خدمات شناسایی شماره‌های شماره‌گیری شده (DNIS) استفاده کنید. دستورات پیکربندی همتای شماره گیری زیر را می توان برای مطابقت با ANI یا DNIS یک تماس استفاده کرد:

  • پاسخ-آدرس
  • الگوی مقصد
  • شماره تماس ورودی
  • نوع شماره گذاری

با استفاده از دستور test translation-rule می توانید قوانین ترجمه خود را آزمایش کنید.

هنگامی که تماس ها از شبکه VoIP به GW وارد می شوند، GW می تواند دستکاری اعداد را انجام دهد. در این مورد، شماره گیری همتا در درگاه POTS می تواند هنگام ارسال اعداد به PSTN، اعداد را حذف یا اضافه کند. شکل 5 عادی سازی اعداد را از شبکه VoIP به PSTN نشان می دهد.

شکل 5 عادی سازی اعداد از VoIP به PSTN

مثال زیر از یک همتای شماره گیری POTS نشان می دهد که چگونه می توان از فرمان پیشوند سیسکو IOS برای افزودن ارقام به شماره تماس استفاده کرد:

dial-peer voice 20 pots
destination-pattern 510…….
prefix 1510

دستور پیشوند قبلی 1510 را جایگزین 510 می کند و به طور موثر یک عدد 1 را به هر الگوی 10 رقمی که با 510 شروع می شود اضافه می کند.

عادی سازی شماره برای نمونه طرح شماره گیری بین المللی
فرض کنید شما یک ارائه دهنده خدمات هستید که برای تماس هایی که از منطقه سان خوزه (کد منطقه 408) منشا می گیرند، انتقال VoIP را ارائه می دهد. مشترکین سن خوزه هنگام برقراری تماس از الگوهای رقمی زیر استفاده می کنند:

•برای تماس های محلی در داخل کد منطقه سن خوزه: از یک شماره 7 رقمی، به عنوان مثال، 555-1000 استفاده کنید.

•برای تماس های راه دور در داخل ایالات متحده: از یک شماره 11 رقمی استفاده کنید، به عنوان مثال، 1-212-555-1000

•برای تماس های بین المللی: از یک کد دسترسی 011، یک کد کشور، یک کد منطقه و شماره، به عنوان مثال، 011-33-10-1111-2222 استفاده کنید.

فرض کنید می خواهید تماس های راه دور از طریق شبکه VoIP انجام شود، اما تماس های محلی از طریق PSTN انجام شود. برای اتخاذ این تصمیم مسیریابی تماس، همیشه باید از GK پرس و جو شود. در این مورد، ARQ از GW تا GK باید در قالب استاندارد باشد:

کد کشور + کد شهر (یا منطقه) + شماره محلی

صرف نظر از اینکه کاربر 7 رقم (تماس محلی)، 11 رقم (تماس از راه دور) یا یک تماس بین المللی با کد دسترسی 011 را شماره گیری کرده است. برای عادی سازی این الگوها باید GW را پیکربندی کنید. منطق نرمال سازی اعداد در شکل 6 نشان داده شده است.

شکل 6 منطق عادی سازی اعداد

در مثال پیکربندی زیر، قوانین ترجمه برای انجام عادی سازی اعداد اعمال می شود:

Hostname SJC-GW
!
translation-rule 2
Rule 0 ^2…… 14082
Rule 1 ^3…… 14083
Rule 2 ^4…… 14084
Rule 3 ^5…… 14085
Rule 4 ^6…… 14086
Rule 5 ^7…… 14087
Rule 6 ^8…… 14088
Rule 7 ^9…… 14089
!
translation-rule 1
Rule 0 ^0111.% 1
Rule 1 ^0112.% 2
Rule 2 ^0113.% 3
Rule 3 ^0114.% 4
Rule 4 ^0115.% 5
Rule 5 ^0116.% 6
Rule 6 ^0117.% 7
Rule 7 ^0118.% 8
Rule 8 ^0119.% 9
!
interface Ethernet0/0
ip address 172.19.49.166 255.255.255.192
h323-gateway voip interface
h323-gateway voip id NA-GK ipaddr 172.19.49.168 1719
h323-gateway voip h323-id US-GW1
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.49.129
no ip http server
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer voice 1408 pots
destination-pattern 14085551000
port 1/0/0
!
dial-peer voice 1 voip
destination-pattern 011T
translate-outgoing called 1
session target ras
!
dial-peer voice 2 voip
destination-pattern 1T
session target ras
!
dial-peer voice 3 voip
destination-pattern [2-9]T
translate-outgoing called 2
session target ras
!
gateway
!

گلوله های زیر نحوه عملکرد عادی سازی اعداد را در مثال قبل خلاصه می کنند:

  • برای تماس های بین المللی، کد دسترسی را حذف کنید
    • قانون ترجمه 1 کد دسترسی 011 را در اعدادی که با 011 شروع می شوند حذف می کند. قانون ترجمه برای شماره گیری همتای 1 اعمال می شود که با تمام اعدادی که با 011 شروع می شوند (یعنی 011T) مطابقت دارد. “T” به عنوان یک علامت عام با فاصله زمانی بین رقمی عمل می کند. ارقام زمانی جمع‌آوری می‌شوند که کاربر در یک زمان معین صدای DTMF را وارد نکند. مقدار پیش‌فرض این زمان 10 ثانیه است و در درگاه صوتی قابل تنظیم (در ثانیه) است. (به بخش “تایم پایان بین رقمی” مراجعه کنید.) کاربر همچنین می تواند پس از وارد کردن رشته رقم کامل یک کاراکتر پایان (#) وارد کند تا نشان دهد که ارقام باید جمع آوری شوند.
  • برای تماس‌های 7 رقمی محلی، کد کشور + کد منطقه (1 408) را اضافه کنید.
    • قانون ترجمه 2 هر عدد 7 رقمی را می گیرد که با 2 تا 9 شروع می شود و یک پیشوند 1408 به آن عدد اضافه می کند که در آن 1 کد کشور و 408 کد منطقه محلی است. این قانون ترجمه برای شماره گیری همتا 3 اعمال می شود که با هر الگوی رقمی که با 2 تا 9 شروع می شود مطابقت دارد.
  • برای تماس های راه دور در داخل ایالات متحده (کد منطقه ای مختلف)، همان قالب را حفظ کنید
    • هیچ قانون ترجمه برای این مورد لازم نیست زیرا الگوی رقم از قبل در قالب مورد نظر است. شماره گیری همتا 2 بدون اعمال قانون ترجمه پیکربندی شده است.

مهلت زمانی بین رقمی

هنگامی که نشانگر زمان پایان “T” در انتهای الگوی مقصد در یک شماره گیری شبکه صوتی خروجی استفاده می شود، روتر ارقام مشخص شده را می پذیرد و سپس منتظر تعداد نامشخصی از ارقام اضافی می شود. تا زمانی که تایمر بین رقمی منقضی نشده باشد، روتر می تواند تا 31 رقم اضافی را جمع آوری کند. وقتی تایمر بین رقمی منقضی می شود، روتر تماس را برقرار می کند.

مقدار پیش‌فرض برای بازه زمانی بین رقمی 10 ثانیه است. با این تنظیم، تمام ارقام 10 ثانیه پس از شماره گیری آخرین رقم جمع آوری می شوند. به عنوان مثال، اگر 9195556789 را شماره گیری کنید، اما بین رقم های 8 و 9 به مدت 11 ثانیه مکث کنید، تنها 919555678 توسط GW جمع آوری می شود. با استفاده از دستور timeouts interdigits در حالت پیکربندی پورت صوتی، می‌توانید مقدار وقفه بین رقمی را تغییر دهید.

توجه داشته باشید که مگر اینکه از کاراکتر # به عنوان پایان‌دهنده در انتهای فرمان مقصد-pattern استفاده شود، T-indicator به طور پیش‌فرض 10 ثانیه به هر تنظیم تماس اضافه می‌کند، زیرا تماس تا پایان زمان سنج انجام نمی‌شود. بنابراین توصیه می‌کنیم در صورت استفاده از طرح‌های شماره‌گیری با طول متغیر، مقدار وقفه بین رقمی را کاهش دهید تا تأخیر پس از شماره‌گیری کاهش یابد.

طرف تماس می‌تواند فوراً با وارد کردن کاراکتر # در زمانی که روتر منتظر ارقام اضافی است، تایمر بین رقمی را خاتمه دهد. با این حال، اگر کاراکتر # به عنوان بخشی از الگوی مقصد با طول ثابت وارد شود که قبل از اینکه روتر منتظر ارقام اضافی باشد وارد شود، به عنوان یک رقم شماره گیری شده در نظر گرفته می شود و هنگام جمع آوری ارقام در سراسر شبکه ارسال می شود. برای مثال، اگر الگوی مقصد به صورت 2222…T پیکربندی شود، کل رشته 99#2222 جمع آوری می شود. اما اگر رشته شماره گیری شده 2222#99#99 باشد، #99 در انتهای ارقام شماره گیری شده جمع آوری نمی شود زیرا کاراکتر # نهایی به عنوان دستور پایان دهنده dial-peer در نظر گرفته می شود.

دستورات برگزیده Peer و گزینه های Failover را شماره گیری کنید
می‌توانید با استفاده از همتاهای شماره‌گیری متعدد با دستور ترجیح، گزینه‌های failover را در GW پیکربندی کنید. فرمان ترجیحی به GW اجازه می‌دهد ابتدا یک همتای شماره‌گیری دلخواه را انتخاب کند، و سپس، اگر GW یک پیام رد پذیرش (ARJ) از GK دریافت کند، GW شماره‌گیری ترجیحی بعدی را انتخاب می‌کند. مقدار ترجیحی پیش فرض 0 است که بالاترین اولویت است. به عنوان مثال اولویت 2 نسبت به اولویت 3 اولویت بیشتری دارد.

این پیکربندی معمولاً به عنوان همتای شماره گیری چرخشی نامیده می شود. این پیکربندی در مواردی مفید است که می‌خواهید برخی از عملکردهای Failover را انجام دهید – اگر اولین شماره‌گیر GW قادر به رفع خاتمه نباشد، از همتای شماره‌گیری ترجیحی بعدی استفاده می‌شود. برای مثالی از عملکرد failover به بخش “استفاده از قوانین ترجمه، پیشوندهای فناوری، و مثال شماره گیری خطای همتا” مراجعه کنید.

در پیکربندی نمونه زیر، دستورات ترجیحی بر روی دو همتای شماره گیری پیکربندی می شوند. ابتدا شماره‌گیری همتای 1 امتحان می‌شود، سپس شماره‌گیری همتای 2:

dial-peer voice 1 voip
destination-pattern 1408…….
session target ras
preference 1
!
dial-peer voice 2 voip
destination-pattern 1408…….
session target osp
preference 2

پیشوندهای فناوری
پیشوندهای فناوری اجازه می دهد تا کاراکترهای ویژه در شماره فراخوانی گنجانده شود. این کاراکترهای ویژه معمولاً به‌عنوان 1#، 2#، 3#، و غیره تعیین می‌شوند و می‌توان آن‌ها را طوری پیکربندی کرد که شماره فراخوانی شده را روی همتای شماره‌گیری VoIP خروجی قرار دهد. سپس GK می تواند جدول پیشوند فناوری GW خود را برای GWهایی که با آن پیشوند فناوری خاص ثبت شده اند بررسی کند. پیشوندهای فناوری همچنین می توانند برای شناسایی یک نوع، کلاس یا مجموعه ای از GW ها استفاده شوند.

دستورات پیشوند فناوری را می توان در هر دو GW و GK در دو مکان وارد کرد، بسته به اینکه چگونه می خواهید هوش تصمیم گیری پیشوند فناوری را طراحی کنید: رابط GW VoIP، یا GW Dial Peer.

پیشوند فناوری در رابط VoIP Gateway
برای درک مزایای بازده مسیریابی که پیشوندهای فناوری ارائه می کنند، GW باید خود را با شماره پیشوند فناوری مانند 1#، 2# و غیره شناسایی کند. این شماره پیشوند را می توان بر روی رابط VoIP GW پیکربندی کرد، همانطور که در مثال زیر نشان داده شده است. در اینجا GW ها پیشوند فناوری خود را با یک پیام درخواست ثبت (RRQ) به دروازه بان ثبت می کنند. این ثبت پیشوند فناوری انتخاب GK یک GW را برای تماس ورودی تعیین می کند.

hostname gw1
!
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
h323-gateway voip tech-prefix 2#

در این مثال، GW1 با 2# به عنوان پیشوند فناوری در GK ثبت می‌شود. این ثبت پیشوند فناوری تعیین می کند که GK کدام GW را برای تماس ورودی انتخاب می کند.

می توانید این ثبت نام را در GK با دستور show gatekeeper gw-type-prefix نمایش دهید:

vn-gk# show gatekeeper gw-type-prefix

GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*
Zone vn-gk master gateway list:
10.71.3.101:1720 gw1

پیشوند فناوری در Gateway Dial Peer
با استفاده از دستورات زیر می توانید یک پیشوند فناوری را روی یک همتای شماره گیری VoIP خاص پیکربندی کنید:

dial-peer voice 1 voip
destination-pattern 1408…….
session target ras
tech-prefix 2#

دستورات قبلی یک #2 را به عدد 1408……. اضافه می کنند. شماره فراخوانی شده 5554000 به 2#14085554000 تبدیل می شود.

وقتی تماسی وارد می‌شود، GK ابتدا به دنبال یک پیشوند فناوری می‌گردد. سپس سعی می کند یک پیشوند منطقه را پیدا کند. باید یک GW پیدا کند که با پیشوند آن منطقه ثبت شده باشد و همچنین با جدول پیشوند منطقه مطابقت داشته باشد. اگر این دو تطابق رخ دهند، GK تماس را به آن دروازه خروج هدایت می کند.

مثال زیر نحوه پیکربندی پیشوند فناوری و نحوه نمایش آن را در GK به همراه پیشوندهای فناوری ثبت شده نشان می دهد:

hostname vn-gw1
!
interface Ethernet0
ip address 10.71.3.101 255.255.255.0
h323-gateway voip interface
h323-gateway voip id vn-gk ipaddr 10.71.3.201 1719
h323-gateway voip h323-id vn-gw1
h323-gateway voip tech-prefix 1#
!
hostname vn-gw2
!
interface Ethernet0/0
ip address 10.71.3.105 255.255.255.0
h323-gateway voip interface
h323-gateway voip id vn-gk ipaddr 10.71.3.201 1719
h323-gateway voip h323-id vn-gw2
h323-gateway voip tech-prefix 2#
!
hostname vn-gk
!
gatekeeper
zone local vn-gk cisco.com 10.71.3.201
zone remote k-gk cisco.com 10.71.3.200 1719
zone remote hopoff cisco.com 10.71.3.202 1719
zone prefix vn-gk 1212*
zone prefix k-gk 1212*
!
no shutdown

vn-gk# show gatekeeper gw-type-prefix
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*
Zone vn-gk master gateway list:
10.71.3.101:1720 vn-gw1

Prefix: 1#*
Zone vn-gk master gateway list:
10.71.3.105:1720 12125557777

اکنون GK دارای vn-gw1 (10.71.3.101) است که با پیشوند 1# ثبت شده است، و اگر تماس های دریافتی با 1# پیشوند به DNIS وارد شوند، این GW را در نظر می گیرد. Vn-gw2 با پیشوند 2# ثبت شده است.

دستورات پیشوند فناوری در دروازه‌بان
دستورات پیشوند فناوری که در بخش‌های زیر توضیح داده شده‌اند در GK موجود هستند تا امکان کنترل تماس اضافی را فراهم کنند.

پیشوند فناوری پیش فرض

دستورات زیر یک پیشوند فناوری پیش فرض را در GK پیکربندی می کنند:

gatekeeper
gw-type-prefix 1# default-technology

اگر هیچ پیشوند فناوری با شماره فراخوانی ارسال نشود، این پیکربندی به GK می‌گوید از GWهایی استفاده کند که با 1# ثبت شده‌اند.

LRQ را به منطقه Hopoff منتقل کنید

دستورات زیر GK را برای دریافت یک پیشوند فناوری خاص پیکربندی می کند و سپس یک پیام LRQ را به منطقه hopoff ارسال می کند:

gatekeeper
gw-type-prefix 7# hopoff spacezone

پس از دریافت یک شماره تماس با 7# قبل از آن، دستگاه یک پیام LRQ را به منطقه فضایی GK ارسال می کند. فضای فضایی hopoff GK نسبت به سایر انتخاب‌های GW اولویت دارد.

پیشوند فناوری استاتیک

دستورات زیر GK را با پیشوند فناوری استاتیک پیکربندی می کند:

gatekeeper
gw-type-prefix 8# gw ipaddr 10.1.1.1

این پیکربندی یک ورودی ثابت در جدول پیشوند نوع GW در GK ایجاد می کند. این معادل داشتن یک GW (آدرس IP 10.1.1.1) با 8# است.

مثال دستورات پیشوند فناوری دروازه‌بان
مثال زیر استفاده از دستورات پیشوند فناوری را نشان می دهد که در بخش های قبل مورد بحث قرار گرفت:

gatekeeper
gw-type-prefix 7#* hopoff spacezone
gw-type-prefix 1#* default-technology
gw-type-prefix 8#* gw ipaddr 10.1.1.1 1720


vn-gk# show gatekeeper gw-type-prefix

GATEWAY TYPE PREFIX TABLE
=========================

Prefix: 7#* (Hopoff zone spacezone)
Zone vn-gk master gateway list:
10.71.3.101:1720 vn-gw1

Prefix: 1#* (Default gateway-technology)
Zone vn-gk master gateway list:
10.71.3.105:1720 12125557777 (Here, 10.71.3.105 GW has registered with a 1#,
so it belongs to the 1# pool)

Prefix: 8#*
Statically-configured gateways: (Not necessarily currently registered)
10.1.1.1:1720

شکل 7 تنظیمات پیشوند فناوری را نشان می دهد. شکل 8 استفاده از پیشوندهای فناوری را در یک شبکه نشان می دهد.

شکل 7 تنظیمات پیشوند فناوری

شکل 8 استفاده از پیشوندهای فناوری در یک شبکه

توجه داشته باشید به طور معمول، هنگامی که یک نقطه پایانی یا GW یک پیام ARQ به GK خود ارسال می کند، GK ابتدا با جستجوی پیشوند فناوری، آدرس مقصد را حل می کند. هنگامی که پیشوند فناوری مطابقت دارد، سپس GK رشته باقیمانده را با پیشوندهای ناحیه شناخته شده مقایسه می کند. اگر آدرس به یک منطقه راه دور حل شود، کل آدرس، از جمله پیشوندهای فناوری و منطقه، در یک پیام LRQ به GK راه دور ارسال می شود. سپس آن GK از راه دور از پیشوند فناوری استفاده می کند تا تصمیم بگیرد که از کدام یک از GW ها استفاده کند. شما می توانید این رفتار را با مرتبط کردن یک منطقه هپوف اجباری با یک پیشوند فناوری خاص لغو کنید. این ارتباط بدون توجه به پیشوند منطقه در آدرس، تماس را به منطقه مشخص شده مجبور می کند.

پیشوندهای منطقه
پیشوند منطقه بخشی از شماره فراخوانی است که منطقه ای را که در آن تماس قطع می شود مشخص می کند. پیشوند منطقه معمولاً شامل منطقه طرح شماره گذاری (NPA) است که به عنوان کد منطقه یا NPA-NXX (کد منطقه و دفتر محلی) نیز شناخته می شود. از آنجایی که هیچ پروتکلی وجود ندارد که دروازه بانان بتوانند به وسیله آن تبلیغ کنند که کدام پیشوند منطقه از ناحیه آنها قابل دسترسی است، این پیشوندهای ناحیه باید به صورت ایستا پیکربندی شوند.

پیشوندهای منطقه معمولاً برای مرتبط کردن یک کد منطقه یا مجموعه ای از کدهای منطقه با یک منطقه پیکربندی شده خاص استفاده می شوند. ابتدا مناطق محلی و راه دور با دستورات زیر بر روی دروازه‌بان تعریف می‌شوند:

gatekeeper
zone local west-gk cisco.com 10.1.1.1
zone remote east-gk cisco.com 10.1.1.2 1719
zone remote central-gk cisco.com 10.1.1.3 1719

سپس، پیشوندهای ناحیه بر روی GW پیکربندی می شوند تا مشخص شود کدام GK کدهای منطقه راه دور را مدیریت می کند:

zone prefix east-gk 312…….
zone prefix west-gk 408…….
zone prefix central-gk 212*

پیکربندی پیشوندهای ناحیه مشابه پیکربندی مسیرهای استاتیک در یک محیط IP است. توجه داشته باشید که در حال حاضر هیچ روشی برای انتشار پویا پلان های شماره گیری به روترها در شبکه وجود ندارد. بنابراین، شما باید این پیشوندهای ناحیه استاتیک را پیکربندی کنید تا به GKها اطلاع دهید که باید LRQها را برای حل و فصل آدرس IP GW یا نقطه پایانی ارسال کنند.

هدف از پیشوند منطقه در GK، مرتبط کردن آدرس E.164 به یک دروازه ترانکینگ خاص است. از آنجایی که GW های ترانکینگ می توانند دامنه ای از آدرس ها را خاتمه دهند، محدوده باید به صورت دستی در GK تعریف شود.

نوع دیگری از نقطه پایانی که می تواند با GK ثبت شود، دروازه آنالوگ یا نقطه پایانی H.323 است. این دستگاه‌ها معمولاً با آدرس کامل E.164 ثبت می‌شوند. در این مورد، پیشوند zone برای پارتیشن بندی یک منطقه خاص H.323 استفاده می شود که این مجموعه از آدرس ها را مدیریت می کند.

شما می توانید با استفاده از دستور show gatekeeper zone prefix، پیشوندهای منطقه ایستا پیکربندی شده را در GK به صورت زیر نمایش دهید:

NA-GK# show gatekeeper zone prefix

ZONE PREFIX TABLE
=================
GK-NAME E164-PREFIX
——- ———–
east-gk 312…….
west-gk 408…….
Central-gk 212*

برای یک پیشوند منطقه خاص (محدوده آدرس های E.164)، می توانید GK را طوری پیکربندی کنید که یک تماس را به یک GW خاص، یا مجموعه ای از GW ها، هر کدام در سطوح اولویت پیکربندی شده ارسال کند. توجه داشته باشید که فقط GW های ثبت شده در حال حاضر از لیست اولویت توسط GK در نظر گرفته می شوند. GWهایی که بیش از حد شلوغ هستند، همانطور که با پیام نشانه در دسترس بودن منبع (RAI) نشان داده شده است، از انتخاب حذف خواهند شد.

می توانید اولویت های GW را از 10 (بالاترین اولویت) تا 0 (استفاده ممنوع) برای پیشوندهای منطقه مختلف در یک منطقه مشخص کنید. اولویت های GW با دستور gw-pri پیاده سازی می شوند، همانطور که در مثال پیکربندی زیر نشان داده شده است:

router-sj(config-gk)# zone local west-gk cisco.com 10.1.1.1
router-sj(config-gk)# zone prefix west-gk 408……. gw-pri 10 gw408
router-sj(config-gk)# zone prefix west-gk 415……. gw-pri 10 gw415
router-sj(config-gk)# zone prefix west-gk 650……. gw-pri 10 gw650
router-sj(config-gk)# zone prefix west-gk 510…….

هر سه GW در مثال اکنون می توانند در یک منطقه ثبت نام کنند. اگر یک پیشوند منطقه دارای اولویت های GW تعریف شده باشد، یک لیست GW جداگانه برای آن پیشوند منطقه نگهداری می شود. لیست شامل تمام GWهای ثبت شده است که بر اساس اولویت مرتب شده اند. هنگامی که یک GW در چنین لیستی درج می شود، اولویت پیش فرض 5 برای GW های بدون نام استفاده می شود.

پیشوندهای منطقه ای که هیچ اولویتی تعریف نشده اند (به عنوان مثال، کد منطقه 510 در مثال قبل) هیچ لیست خاصی مرتبط با آنها ندارند. تماس با کد منطقه 510 خارج از لیست اصلی GW برای منطقه انجام می شود.

با پیکربندی قبلی، زمانی که gw408 ثبت می‌کند، در لیست 408 در اولویت 10 قرار می‌گیرد و در لیست‌های 415 و 650 با اولویت پیش‌فرض 5 قرار می‌گیرد. وقتی هر سه GW ثبت می‌شوند، لیست منطقه مانند زیر خواهد بود:

resultant Master list
master list: gw408, gw415, gw650
408 list: pri 10 gw408; pri 5 gw650, gw415
415 list: pri 10 gw415; pri 5 gw650, gw408
650 list: pri 10 gw650; pri 5 gw408, gw415

هر تماس با کد منطقه 408 به gw408 هدایت می شود زیرا بالاترین اولویت را دارد. با این حال، اگر gw408 مشغول باشد (مثلاً یک پیام RAI ارسال کرده است که تقریباً منابعش تمام شده است)، تماس به gw415 یا gw650 هدایت می شود. اگر نمی‌خواهید از هیچ یک از این GWها برای تماس‌های 408 استفاده شود، می‌توانید مشخص کنید که آنها اولویت صفر برای آن کد منطقه دارند، همانطور که در پیکربندی زیر نشان داده شده است:

router-sj(config-gk)# zone prefix west-gk 408……. gw-pri 10 gw408
router-sj(config-gk)# zone prefix west-gk 408……. gw-pri 0 gw415 gw650

این پیکربندی تضمین می کند که فقط gw408 برای تماس با کد منطقه 408 استفاده می شود.

باید توجه داشته باشید که لیست های اولویت GW با برخی هزینه های سربار همراه است و باید با احتیاط از آنها استفاده کرد. اگر می توانید مناطق خود را برای جلوگیری از استفاده از اولویت های GW تقسیم بندی کنید، باید این کار را انجام دهید. اگر باید از این ویژگی استفاده کنید، سعی کنید تعداد پیشوندهای منطقه با تعاریف اولویت را کمتر از 50 در هر منطقه نگه دارید زیرا هر GW ثبت شده در یک منطقه باید در هر لیست اولویت بندی شده در آن منطقه درج شود و از همه لیست ها حذف شود. زمانی که آن را لغو ثبت می کند.

همانطور که دیدیم، پیشوندهای منطقه برای شناسایی کدهای منطقه خاص با مناطق ایجاد شده ایجاد می شوند. GW های خاص در داخل منطقه می توانند اولویت بندی شوند تا GK ابتدا تماس را به آن GW ها واگذار کند.

کاهش تاخیر پس از شماره گیری
هنگامی که یک پلن شماره گیری در مقیاس بزرگ طراحی می کنید، باید اثرات تاخیر پس از شماره گیری در شبکه را در نظر بگیرید. تأخیر پس از شماره گیری زمان از شماره گیری آخرین رقم تا لحظه زنگ زدن تلفن در محل دریافت است. طراحی ناحیه GW و GK، قوانین ترجمه و LRQهای متوالی همگی بر تأخیر پس از شماره گیری تأثیر می گذارند. سعی کنید از این ابزارها به بهترین شکل برای کاهش تاخیر پس از شماره گیری استفاده کنید.

مناطق هوپوف
منطقه hopoff به نقطه ای اشاره دارد که در آن فراخوانی از H.323 به غیر H.323 (به عنوان مثال، PSTN یا H.320) از طریق یک GW تغییر می کند. شما می توانید یک GK را برای مدیریت منطقه ای که برای سرویس دهی به ترافیکی که محلی نیست، پیکربندی کنید. به عنوان مثال، اگر تلفن A با شماره 3155559999 تماس بگیرد، که خارج از کدهای منطقه محلی تعریف شده توسط GK X است، می توان یک منطقه hopoff را برای رسیدگی به چنین شماره تلفن هایی پیکربندی کرد. در دنیای IP، یک ناحیه هپوف را به عنوان یک GW پیش فرض در نظر بگیرید.

منطقه hopoff همراه با پیشوندهای فناوری استفاده می شود و به عنوان یک گزینه با دستور gw-type-prefix پیکربندی می شود، همانطور که در مثال زیر نشان داده شده است:

gatekeeper
gw-type-prefix 2# hopoff hopoffgk

این پیکربندی اغلب به عنوان پیشوند اجباری فناوری نامیده می شود. یک نمونه پیکربندی در شکل 9 نشان داده شده است.

شکل 9 کاربرد منطقه Hopoff

در شکل 9، یک ناحیه هوپوف اضافه شده است که از یک هوپوف GW و یک هوپوف GK تشکیل شده است. WestGK و DGK با یک دستور static gw-type-prefix پیکربندی شده اند. این دستور باعث می شود که همه شماره های فراخوانی شده با پیشوند فناوری 2# یک پیام LRQ را به hopoff GK بعدی خود ارسال کنند. در این حالت، WestGK این پیام های LRQ را به DGK و DGK آنها را به HopoffGK ارسال می کند.

توجه داشته باشید که SFGW با دو همتای شماره گیری پیکربندی شده است. دستور preference ترتیب شماره گیری همتا را اختصاص می دهد. این دستور عموماً برای اهداف Failover استفاده می‌شود که الگوی مقصد یکسانی را به چندین همتای شماره‌گیری اختصاص دهید.

شماره گیری همتا 1 ابتدا یک پیام ARQ به WestGK می فرستد تا مشخص کند که آیا شماره فراخوانی شده پایان دهنده آدرس GW را می داند یا خیر. اگر WestGK آدرس GW پایان دهنده را نداند، WestGK یک پیام ARJ به GW ارسال می کند. شماره گیری دوم یک پیشوند فناوری 2# را به شماره تماس گرفته شده اضافه می کند و دوباره یک پیام ARQ را به WestGK امتحان می کند. این بار، 2# با دستور gw-type-prefix 2# مطابقت دارد تا به DGK برود. DGK همچنین 2# را می شناسد و دستور gw-type-prefix 2# را برای پرش به HopoffGK مطابقت می دهد. توجه داشته باشید که 2# با شماره فراخوانی شده منتشر می شود.

می‌توانید کلمه کلیدی hopoff و شناسه دروازه‌بان را چندین بار در یک دستور وارد کنید تا گروهی از GKها را تعریف کنید که پیشوند فناوری خاصی را ارائه می‌کنند. فقط یکی از GK ها در لیست hopoff می تواند محلی باشد.

اگر پیشوند فناوری هیچ ویژگی منطقه اجباری نداشته باشد، GK از تطبیق پیشوند منطقه برای تعیین منطقه استفاده می کند. اگر پیشوند منطقه تطبیق با یک منطقه راه دور مرتبط باشد، یک پیام LRQ به GK راه دور ارسال می شود. پیام LRQ شامل کل شماره فراخوانی شده است، از جمله پیشوند فناوری که قبلاً حذف شده است. اگر پیشوند منطبق برای یک منطقه محلی باشد، از آن منطقه برای برآورده کردن درخواست استفاده می شود.

اگر هیچ تطابقی پیشوند منطقه پیدا نشد، رفتار پیش‌فرض این است که سعی کنید از یک منطقه محلی برای hopoff استفاده کنید تا اینکه تماس را شکست دهید. با این حال، رفتار پیش فرض ممکن است رفتار مطلوب نباشد. ممکن است ترجیح دهید که یک پیام ARJ به GW برگردانده شود تا بتواند به یک همتای شماره گیری جایگزین بیفتد – برای مثال، پیامی که مشخص می کند که جهش بعدی از طریق یک PSTN با نرخ ویژه است. برای نادیده گرفتن رفتار پیش‌فرض، از دستور arq reject-unknown-prefix در حالت پیکربندی دروازه‌بان استفاده کنید.

در دسترس بودن و تحمل خطا
در طول طراحی طرح شماره گیری خود، باید در دسترس بودن شبکه و میزان موفقیت تماس را در نظر بگیرید. تحمل خطا و افزونگی در شبکه‌های H.323 بیشترین اهمیت را در سطح دروازه‌بان دارند. استفاده از GK جایگزین، LRQهای متوالی و پروتکل مسیریابی آماده به کار داغ (HSRP) به ارائه افزونگی و تحمل خطا در شبکه H.323 کمک می کند. از Cisco IOS Release 12.2، افزونگی GK را می توان برای GKهای جایگزین و HSRP برای GKها پیکربندی کرد.

دروازه بان با HSRP
از آنجایی که GK بیشتر هوش مسیریابی تماس (جدول پیشوند منطقه، جداول پیشوند فناوری و ثبت E.164) را حفظ می کند، GK باید تحمل خطا داشته باشد. می‌توانید GKها را برای استفاده از HSRP به گونه‌ای پیکربندی کنید که وقتی یک GK از کار می‌افتد، GK آماده به کار نقش خود را برعهده بگیرد، همانطور که در شکل 10 نشان داده شده است.

یک GK فعال و یک GK آماده به کار را برای قرار گرفتن در یک زیرشبکه پیکربندی کنید. بنابراین، GK ها را با هم پیدا کنید. HSRP از یک طرح اولویت استفاده می کند تا مشخص کند کدام روتر پیکربندی شده با HSRP، روتر فعال پیش فرض است. برای پیکربندی روتر به‌عنوان روتر فعال، اولویتی را به آن اختصاص می‌دهید که از اولویت دیگر روترهای پیکربندی شده HSRP بیشتر است. اولویت پیش فرض 100 است، بنابراین اگر فقط یک روتر را برای داشتن اولویت بالاتر پیکربندی کنید، آن روتر روتر فعال پیش فرض خواهد بود.

HSRP با تبادل پیام های چندپخشی کار می کند که اولویت را در بین روترهای پیکربندی شده HSRP تبلیغ می کند. هنگامی که روتر فعال نتواند پیام سلام را در یک دوره قابل تنظیم ارسال کند، روتر آماده به کار با بالاترین اولویت، پس از پایان زمان تایمر نگه داشتن، روتر فعال می شود. فرمان پیکربندی رابط تایمرهای آماده به کار، فاصله زمانی (1 تا 255 ثانیه) را بین پیام‌های hello تنظیم می‌کند و زمان (1 تا 255 ثانیه) را تعیین می‌کند که روتر قبل از اعلام خاموش بودن روتر فعال منتظر بماند. پیش فرض ها به ترتیب 3 ثانیه و 10 ثانیه هستند. اگر تصمیم دارید مقادیر پیش‌فرض را تغییر دهید، باید هر روتر را طوری پیکربندی کنید که از همان زمان hello و زمان نگهداری استفاده کند.


توجه داشته باشید در طول زمانی که دروازه‌بان فعال HSRP به HSRP GK آماده به کار منتقل می‌شود، عملکرد GK از بین می‌رود و نمی‌تواند به LRQ‌های جدید پاسخ دهد. وقتی HSRP روی دروازه‌بان دایرکتوری اعمال شود، دروازه‌بان دایرکتوری ثانویه به این مشکل رسیدگی می‌کند.

شکل 10 HSRP در Gatekeeper

در شکل 10، توجه کنید که یک آدرس مجازی 10.50.1.1 هم روی WestGK و هم در GK پشتیبان پیکربندی شده است. SFGW با این آدرس مجازی با دستور h323 voip id ثبت نام می کند.

ما استفاده از HSRP را در سطح DGK توصیه می‌کنیم زیرا شکست از HSRP DGK اولیه به HSRP DGK ثانویه به دلیل زمان مورد نیاز برای ارسال LRQهای متوالی، زمان کمتری نسبت به استفاده از GK جایگزین به عنوان پشتیبان اصلی می‌برد. بعداً در این سند در مورد استفاده توصیه شده از DGK ثانویه بحث خواهیم کرد.

دروازه بان های جایگزین
در سیستمی که از GK ها استفاده می شود، ویژگی دروازه بان جایگزین، افزونگی را فراهم می کند. این بهبود به یک GW اجازه می دهد تا از دو GK جایگزین برای تهیه یک نسخه پشتیبان در صورت خرابی GK اولیه استفاده کند. به طور خاص، می توانید یک GW را برای ثبت با دو GK پیکربندی کنید. اگر اولین GK از کار بیفتد، می‌توان از GK جایگزین برای مسیریابی تماس استفاده کرد و مسیریابی تماس را بدون شکست تماس حفظ می‌کند.

در مثال زیر، GW برای ثبت با دو GK پیکربندی شده است. اولویت پیش فرض 127 (کمترین اولویت) است. 1 بالاترین اولویت است.

interface Ethernet 0/1
ip address 172.18.193.59 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK1 ipaddr 172.18.193.65 1719 priority 120
h323-gateway voip id GK2 ipaddr 172.18.193.66 1719
h323-gateway voip h323-id cisco2

در این مثال، ما 172.18.193.65 را به عنوان GK اولیه و 172.18.193.66 را به عنوان GK ثانویه پیکربندی کرده ایم.

در شکل 11، توجه داشته باشید که تنظیمات در WestGK و WestAltGK با توجه به مناطق محلی و دوردست آنها بسیار شبیه است. توجه داشته باشید که یک پیشوند ناحیه ورودی westaltgk 415* در WestGK و پیشوند منطقه westgk 415* در WestAltGK وجود دارد. این ورودی ها در شرایطی که به شرح زیر توضیح داده شده ضروری می شوند.

فرض کنید دو GW در SF POP دارید که هر دو در WestGK (دروازه بان اصلی) ثبت شده اند. WestGK به مدت 30 ثانیه شکست را تجربه می کند، سپس دوباره فعال می شود. در طول شکست 30 ثانیه ای، GW1 مجدداً در WestAltGK ثبت می شود زیرا تایمر RRQ 60 ثانیه ای آن منقضی می شود. با این حال، تایمر GW2 RRQ در این پنجره زمانی منقضی نمی شود و GW2 در WestGK ثبت می شود. سپس موردی داریم که در آن GW ها در دو GK مختلف ثبت می شوند. دستور پیشوند منطقه اضافی تضمین می کند که GK GK مجاور را برای GWهایی که با آن ثبت نشده اند بررسی می کند.

شکل 11 GK جایگزین در ناحیه GKs

Cisco IOS Release 12.2 قابلیتی را معرفی کرد که می تواند LRQ ها را به صورت متوالی به جای پخش تک پخشی LRQ ارسال کند. این یک مزیت قابل توجه نسبت به HSRP است زیرا GK های پشتیبان دیگر نیازی به قرار گرفتن در همان منطقه جغرافیایی ندارند.

خوشه های دروازه بان
راه دیگر برای ارائه افزونگی GK و اشتراک بار، پیکربندی GK ها در یک خوشه است. شما می توانید پنج GK در یک خوشه داشته باشید. اعضای یک خوشه GK با استفاده از پروتکل Gatekeeper Update Protocol (GUP)، یک پروتکل اختصاصی Cisco بر اساس TCP، با یکدیگر ارتباط برقرار می کنند. شکل 12 پنج GK را در یک خوشه نشان می دهد.

شکل 12 یک خوشه دروازه بان

هر GK در خوشه برای دانستن آدرس های IP اعضای GK پیکربندی شده است. پس از راه‌اندازی، هر GK یک پیام درخواست دروازه‌بان (GRQ) از سایر GKها دریافت می‌کند. این پیام GRQ دارای اطلاعات GK جایگزین است که در بخش غیر استاندارد پیام جاسازی شده است. در این مرحله، یک GK در یک خوشه، یک اتصال TCP را با تمام GK های دیگر در خوشه باز می کند. به روز رسانی GUP توسط هر GK در فواصل 30 ثانیه ارسال می شود.

پیام های GUP
پیام‌های زیر توسط GKs در یک خوشه ارسال می‌شوند:

  • AnnouncementIndication—به صورت دوره ای، هر 30 ثانیه به صورت پیش فرض، توسط هر عضو GK خوشه ارسال می شود. هنگامی که یک GK این پیام را دریافت می کند، اطلاعات مربوط به ظرفیت تماس، ظرفیت نقطه پایانی، بار CPU، میزان مصرف حافظه، تعداد تماس ها و تعداد نقاط پایانی ثبت شده GK جایگزین (فرستنده) را به روز می کند.
  • AnnouncementReject—در صورت عدم تطابق پیکربندی ارسال می شود. گیرنده خطا را نمایش می دهد و اتصال GUP را با فرستنده قطع می کند.
  • RegistrationIndication—زمانی که اتصال GUP با یک GK جایگزین جدید ایجاد می شود، یا زمانی که یک نقطه پایانی جدید با GK ثبت می شود، ارسال می شود.
  • UnregistrationIndication—زمانی که یک نقطه پایانی قدیمی شده است یا GK بسته می شود، یا زمانی که یک نقطه پایانی با GK لغو ثبت می شود ارسال می شود.
  • ResourceIndication—زمانی که GK یک پیام RAI از GW دریافت می کند ارسال می شود.

پروتکل GUP
اعلامیه های GUP سایر GK ها را در مورد استفاده از حافظه GK و CPU، تعداد نقاط پایانی ثبت شده و پهنای باند استفاده شده و در دسترس مطلع می کند. اطلاعات استفاده از حافظه و CPU به مدیریت منابع خوشه کمک می کند زیرا در هر زمان معینی هر GK در خوشه دارای اطلاعات بار، CPU، حافظه و ظرفیت تماس است. اگر این GK بیش از حد بارگذاری شود، می‌تواند از نقطه پایانی بخواهد که از منابع GK جایگزین با کمترین بار استفاده کند.

هر GK اطلاعات نقطه پایانی ثبت شده را از سایر GKها دریافت می کند. بنابراین، اطلاعات مربوط به هر نقطه پایانی، ثبت شده در هر GK در یک خوشه، را می توان از هر عضو GK به دست آورد، که به پردازش LRQ کمک می کند. اکنون هر GK در خوشه می تواند درخواست های LRQ ارسال شده از یک GK خارجی را حل کند.

هنگامی که یک نقطه پایانی جدید با یک GK در یک خوشه ثبت می شود، آن GK یک پیغام registerIndication توسط GUP ارسال می کند. به طور مشابه، یک پیام unregistrationIndication ارسال می شود که یک نقطه پایانی از ثبت نام خارج می شود. اگر یک GK در یک خوشه شش به‌روزرسانی متوالی GUP را ارسال نکند، توسط همه اعضای GK به‌عنوان پایین علامت‌گذاری می‌شود.

هنگامی که یک نقطه پایانی با یک پیام پاسخ درخواست اطلاعات (IRR) به یک GK در مورد یک تماس جدید اطلاع می‌دهد، GK تعداد کل تماس‌های فعالی را که نظارت می‌کند افزایش می‌دهد و این داده‌ها را توسط GUP ارسال می‌کند.

اگر یک GK به دلیل یک استثنا نرم افزاری یا قطع برق از کار بیفتد، نقاط پایانی بار متعادل می شوند. تعادل بار در طی پیام تأیید ثبت اولیه (RCF) به دست می آید. پیام RCF اولیه حاوی لیستی از GKهای جایگزین است که به ترتیب اولویت فهرست شده است، که اگر این GK (اولیه) به پیام‌های RAS پاسخ ندهد، نقطه پایانی می‌تواند ثبت نام کند.

وقتی GK اولیه نتواند به پیام‌های درخواست ثبت (RRQ) پاسخ دهد، نقطه پایانی سعی می‌کند تا با دیگر GK‌های موجود در خوشه، به ترتیب اولویت، همانطور که در RCF دیکته شده است، ثبت نام کند. به محض ثبت نقطه پایانی، یک پیام درخواست اطلاعات (IRQ) توسط GK ارسال می‌شود تا اطلاعات مربوط به همه تماس‌هایی را که در حال حاضر در نقطه پایانی در حال انجام هستند، دریافت کند و اطمینان حاصل شود که اطلاعات تماس به دلیل قطعی در GK از بین نمی‌رود.

هنگامی که منابع GK بیش از حد بارگذاری می شوند (دیگر ظرفیت تماس وجود ندارد)، می تواند نقاط پایانی خود را به یک GK جایگزین در خوشه که منابع کافی دارد هدایت کند. تغییر مسیر نقاط پایانی با ارسال یک پیام رد ARJ یا RRJ در پاسخ به یک پیام ARQ یا RRQ انجام می شود. پیام ARJ یا RRJ حاوی آدرس IP GK جایگزینی است که باید استفاده شود. پس از دریافت این پیام، نقطه پایانی سعی می کند با GK جایگزین جدید ثبت نام کند و پردازش تماس جدید را ادامه دهد.

دروازه بان دایرکتوری ثانویه
یک دروازه‌بان دایرکتوری ثانویه می‌تواند برای پشتیبان‌گیری از دروازه‌بان دایرکتوری دیگر با استفاده از ویژگی LRQ متوالی استفاده شود. برای مثال، اگر یک منطقه GK یک LRQ به یک DGK اولیه بفرستد و نتواند یک LCF را دریافت کند، یک LRQ دیگر (متوالی) می تواند از منطقه GK به این GK جایگزین ارسال شود. سپس DGK ثانویه جستجوی پیشوند DGK معمولی و مسیریابی تماس را در شبکه فراهم می کند تا زمانی که DGK اولیه بتواند دوباره کار کند. این طرح را در مثال شکل 13 اعمال می کنیم.

توصیه های طراحی دروازه بان دایرکتوری
توصیه می کنیم از ترکیبی از GK جایگزین، HSRP DGK و DGK ثانویه برای ارائه تحمل خطا و افزونگی در شبکه های بزرگتر H.323 استفاده کنید. شکل 13 توپولوژی شبکه را نشان می دهد.

شکل 13 توصیه طراحی مقاوم در برابر خطا

در توپولوژی شبکه نشان داده شده در شکل 13، تحمل خطا و افزونگی به صورت زیر پیاده سازی شده است:

  • GK جایگزین در سطح منطقه
    • GW ها به گونه ای پیکربندی شده اند که در یک GK اولیه و به یک GK جایگزین در صورت شکست GK اولیه ثبت نام کنند. در هر زمان معین، یک GW ممکن است در GK اصلی یا جایگزین آن ثبت شود. برای تطبیق تقسیم بندی ناحیه، باید LRQ های متوالی را روی GK ها و DGK ها پیکربندی کنید زیرا GK های Cisco حالت های ثبت نام را به یکدیگر منتقل نمی کنند.
  • جفت HSRP در سطح DGK
    • HSRP برای ارائه تحمل خطا برای DGK استفاده می شود. زمان شکست HSRP را می توان همانطور که در بخش HSRP این سند مشخص شده است، پیکربندی کرد. یک آدرس IP مجازی واحد بین دو HSRP DGK مشترک است. Zone GK ها فقط باید به این آدرس مجازی اشاره کنند.
  • DGK ثانویه در سطح DGK
    • تشخیص شکست HSRP ممکن است مدتی طول بکشد و در طی آن هیچ تماسی پردازش نخواهد شد. برای پوشش این مورد، می توانید GK های محلی را طوری پیکربندی کنید که به یک DGK ثانویه اضافی اشاره کنند. استفاده از LRQ های متوالی در سطح GK مورد نیاز است. در طول این مدت، تماس‌ها همچنان تکمیل می‌شوند، اما با تأخیر اضافی پس از شماره‌گیری. DGK جایگزین مانند جفت HSRP DGK اولیه پیکربندی شده است (پیام های 2a و 2b را در ادامه این بخش ببینید).

در زیر جریان شکست سطح بالا برای توپولوژی نشان داده شده در شکل 13 است. فرض کنید یک کاربر در SF POP با 12125551000 در NY POP تماس می گیرد.

1. LRQ is sent from WesternGK to DGK.

1a. LRQ is sent from DGK to EasternGK, with no response from EasternGK.

1b. LRQ is sent from DGK to EasternAltGK (sequential LRQ).

یا EasternGK یا EasternAltGK بسته به اینکه شرایط 1a یا 1b وجود داشته باشد LCF را به WesternGK برمی گرداند.

فرض کنید یکی از DGK ها از کار بیفتد. در این مورد، فرض کنید DGK1 اصلی است و با شکست مواجه می شود. HSRP برای فعال کردن ثانویه، DGK2 عمل می کند. مدتی در طول این شکست سپری خواهد شد. در طول این زمان شکست، هیچ تماس جدیدی نمی تواند پردازش شود زیرا هیچ یک از DGK پاسخ نمی دهند. برای ارائه افزونگی برای این بازه، از یک DGK ثانویه برای دریافت LRQ در این مدت استفاده کنید.

جریان تماس از منطقه غربی به منطقه شرقی به شرح زیر است:

1. LRQ is sent from WesternGK to DGK; no response from DGK (HSRP failover interval).

2. Second LRQ is sent from WesternGK to AltDGK (sequential LRQ).

2a. LRQ is sent from AltDGK to EasternGK; no response from EasternGK.

2b. LRQ is sent from AltDGK to EasternAltGK.

یا EasternGK یا EasternAltGK بسته به اینکه شرایط 2a یا 2b وجود داشته باشد، LCF را به WesternGK برمی گرداند.

اجزای شبکه H.323 در طرح های شماره گیری در مقیاس بزرگ
این بخش اجزای اساسی یک شبکه H.323 و برخی از دستورات پیشرفته Cisco IOS را که می‌توان در هنگام طراحی طرح‌های شماره‌گیری شبکه ارائه‌دهنده خدمات در مقیاس بزرگ مورد استفاده قرار داد، مورد بحث قرار می‌دهد. این مؤلفه‌ها دروازه‌ها، دروازه‌بان‌ها و دروازه‌بان‌های فهرست هستند.

دروازه ها در طرح های شماره گیری در مقیاس بزرگ
به عنوان رابط بین PSTN و شبکه IP، یک GW مسئول تصمیمات مسیریابی لبه است. GW شامل پیکربندی همتای شماره گیری می شود و اعداد PSTN را قبل از ورود به شبکه IP عادی می کند و اعداد را از شبکه IP قبل از ورود به PSTN عادی می کند. GW برای مدیریت منابع خود با تبادل پیام های RAS در یک GK ثبت نام می کند.

دروازه بانان در طرح های شماره گیری در مقیاس بزرگ
همانطور که دروازه های VoIP بیشتری به شبکه اضافه می شوند، مدیریت افزودن و تغییر شماره گیری های همتا در تمام GW های VoIP راه دور می تواند غیرقابل مدیریت شود. برای ارائه مدیریت طرح شماره گیری متمرکز، می توانید یک دروازه بان به شبکه دروازه به دروازه اضافه کنید. دروازه‌بان‌ها به شما این امکان را می‌دهند که شبکه را به‌طور منطقی به مناطق تقسیم کنید و طرح شماره‌گیری را به‌طور مرکزی مدیریت کنید.

توجه: منطقه مجموعه ای از نقاط پایانی، دروازه ها، یا واحدهای کنترل چند نقطه ای (MCU) است که در یک GK ثبت شده است. یک سیسکو IOS GK می تواند چندین منطقه را کنترل کند. یک GK را در نظر بگیرید که چندین منطقه را به عنوان چندین GK منطقی که روی یک روتر وجود دارند، کنترل می کند. GK منطقی با نام GK مشخص می شود که نام منطقه نیز می باشد. هنگامی که یک Cisco IOS GK پیکربندی می شود، هر منطقه ای که توسط این روتر کنترل می شود، منطقه محلی نامیده می شود. هر منطقه ای که توسط روتر دیگری کنترل می شود، منطقه راه دور نامیده می شود.

بدون GK، آدرس‌های IP صریح برای هر GW پایانه باید روی GW مبدأ پیکربندی شده و با یک شماره‌گیری همتای VoIP مطابقت داده شود. با وجود GK، GW های VoIP راه دور به سادگی به طرح شماره گیری در GK اشاره می کنند که در تلاش برای برقراری تماس های VoIP با سایر GW های VoIP راه دور هستند.

هنگامی که یک GK به شبکه اضافه می شود، GWs به شکل یک آدرس E.164، نام مستعار ایمیل یا شناسه H.323 در آن GK ثبت می شود. سپس GK اطلاعات مسیریابی تماس را حفظ خواهد کرد. GW ها می توانند این اطلاعات را در پیام RAS ARQ با اشاره کردن هدف جلسه به کلمه کلیدی ras جستجو کنند. این پیکربندی تعداد همتاهای شماره گیری لازم در GW را کاهش می دهد.

برای هر GW ثبت شده محلی، GK اطلاعاتی در مورد پیشوندهایی دارد که GW پشتیبانی می کند. در GK، این پیشوندها با استفاده از دستور zone prefix به صورت ایستا تعریف می شوند. در ایالات متحده، کدهای منطقه معمولاً با پیشوند منطقه نشان داده می شوند. در کشورهای اروپایی، پیشوندها ممکن است به عنوان کد شهر یا منطقه نمایش داده شوند. علاوه بر این که شامل پیشوندهای محلی است، GK حاوی اطلاعاتی در مورد پیشوندهایی است که توسط هر GK از راه دور در شبکه پشتیبانی می شود. GK مسئول در نهایت ارائه آدرس GW پایانی به GW مبدأ است. این آدرس می‌تواند یک منبع محلی باشد، یا GK می‌تواند از هر یک از GKهای راه دور خود برای ارائه یک آدرس GW پایانی درخواست کند.

GK باید تماس‌های مسیریابی را که وارد فضای ابری IP می‌شوند ردیابی کند. این مسیریابی معمولاً بر روی پیشوندهای E.164 انجام می شود. GK باید ردیابی کند که کدام سرویس GW کدام پیشوند دارد، و کدام پیشوند در GK های راه دور قرار دارد، و باید مدیریت منابع و ثبت های GW را حفظ کند.

شکل 14 شبکه H.323 دروازه‌بان به دروازه‌بان را با سه GK نشان می‌دهد. هر GK یک منطقه را مدیریت می کند و مسئول مدیریت تماس ها به منطقه اختصاصی خود است. GW ها در هر منطقه ساکن هستند و توسط پیام های RAS در GK مربوطه خود ثبت می شوند.

شکل 14 شبکه Gatekeeper-to-Gatekeeper، کاملا مشبک شده

یک جدول پیشوند منطقه ایستا بر روی هر یک از GK ها در شکل 14 پیکربندی شده است. هر GK با پیشوندهای ناحیه نشان داده شده در پیکربندی زیر پیکربندی شده است:

hostname WesternGK
!
gatekeeper
zone local WesternGK cisco.com 10.1.1.1
zone remote CentralGK cisco.com 10.2.1.1 1719
zone remote EasternGK cisco.com 10.3.1.1 1719
zone prefix WesternGK 415* gw-priority 10 SFGW
zone prefix CentralGK 312*
zone prefix EasternGK 212*
!
hostname CentralGK
!
gatekeeper
zone local CentralGK cisco.com 10.2.1.1
zone remote WesternGK cisco.com 10.1.1.1 1719
zone remote EasternGK cisco.com 10.3.1.1 1719
zone prefix CentralGK 312* gw-priority 10 ChicagoGW
zone prefix WesternGK 415*
zone prefix EasternGK 212*
!
hostname EasternGK
!
gatekeeper
zone local EasternGK cisco.com 10.3.1.1
zone remote CentralGK cisco.com 10.2.1.1 1719
zone remote WesternGK cisco.com 10.1.1.1 1719
zone prefix EasternGK 212* gw-priority 10 NYGW
zone prefix CentralGK 312*
zone prefix WesternGK 415*
!

توجه داشته باشید فرمان پیشوند zone با جزئیات بیشتری در بخش “پیوندهای منطقه” این سند پوشش داده شده است.

زیر جریان تماس برای شکل 14 است. برای این مثال، فرض کنید تلفنی از SFGW (408-555-1000) با تلفنی در NYGW (212-555-3400) تماس می گیرد.

  1. SFGW یک پیام ARQ به WesternGK ارسال می کند و آدرس NYGW را درخواست می کند.
  2. WesternGK به جدول پیشوند منطقه خود نگاه می کند تا مشخص کند که آیا می داند پیشوند 212 در کجا قرار دارد یا خیر.
  3. از جدول مسیریابی، WesternGK تأیید می کند که 212 کد منطقه در EasternGK قرار دارند، بنابراین یک پیام LRQ به EasternGK ارسال می کند.
  4. EasternGK جدول مسیریابی خود را بررسی می کند و تأیید می کند که منطقه محلی آن کد منطقه 212 را ارائه می دهد. همچنین تأیید می‌کند که NYGW GW پایان‌دهنده دقیق شماره تلفن‌های کد منطقه ۲۱۲ است.
  5. EasternGK یک پیام LCF حاوی آدرس IP NYGW به WesternGK ارسال می کند.
  6. WesternGK این پیام LCF را دریافت می کند و یک پیام ACF، حاوی آدرس NYGW، به SFGW می فرستد.
  7. SFGW یک پیام راه اندازی RAS به NYGW ارسال می کند تا ارتباط صوتی همتا به همتا و جریان RTP را آغاز کند.

مثال قبلی روترهایی را نشان می دهد که برای یک پیکربندی کاملا مشبک برای جداول مسیریابی پیکربندی شده اند. هر GK باید دارای یک پیشوند منطقه ثابت پیکربندی شده برای هر یک از مناطق دوردست مجاور باشد.

با این حال، این پیکربندی کاملا مشبک دارای محدودیت هایی است. اگر یکی از GK های محلی قرار باشد پیشوند دیگری اضافه کند یا پیشوندی را تغییر دهد، باید تغییرات پیشوند منطقه در هر GK در شبکه کاملا مشبک انجام شود. به همین ترتیب، اگر یک منطقه یا GK جدید اضافه شود، همه GK ها باید این تغییر را منعکس کنند. پیکربندی مجدد این GK ها هر بار که یکی از این تغییرات رخ می دهد یک بار اداری خواهد بود.

دروازه‌بان‌های دایرکتوری در پلان‌های شماره‌گیری در مقیاس بزرگ
دروازه‌بان‌های دایرکتوری تدارک شبکه‌های بزرگ را ساده می‌کنند. آنها به شما این امکان را می دهند که الزامات پیکربندی را به یک منطقه محلی بدون نیاز به ارائه کل شبکه برای تغییرات محلی محدود کنید. محدود کردن الزامات پیکربندی به یک منطقه محلی به ویژه در شبکه‌هایی که اعداد محلی ممکن است در مقایسه با طرح شماره‌گیری عمومی کشور بیشتر تغییر کنند، مهم است. به عنوان مثال، اگر مبادلات اضافه شوند یا مراکز نرخ تغییر کنند، این پیکربندی‌ها می‌توانند در ناحیه محلی ایزوله شوند و در بقیه شبکه منتشر نشوند.

شکل 15 شبکه کاملا مشبک شده از شکل 14 را با DGK اضافه شده نشان می دهد. توجه داشته باشید که هر GK محلی باید فقط با اطلاعات محلی خود پیکربندی شود. بقیه شبکه برای رزولوشن از DGK “مسیر ستاره ای” خارج می شود. این پیکربندی به GK ها اجازه می دهد فقط از تغییرات محلی خود آگاه باشند و بقیه شبکه را از نیاز به مقابله با هرگونه تغییر محلی جدا می کند. DGK تنها دستگاهی است که نیاز به دانستن طرح شماره گیری کلی دارد.

مفهوم شبیه به Frame Relay WAN است. فرض کنید باید یک شبکه کاملا مشبک با تعداد زیادی نقشه شماره گیر که به هر یک از روترهای مجاور در فضای ابری اشاره دارد، پیکربندی کنید. با استفاده از هاب Frame Relay و پیکربندی اسپیکر، می توانید تمام جریان ترافیک را از طریق یک روتر هاب برای دسترسی به روترهای مجاور داشته باشید. فقط باید نقشه های شماره گیر را روی روتر هاب پیکربندی کنید.

همین مفهوم را می توان در شبکه های H.323 با معرفی DGK اعمال کرد. DGK مرکزی برای جداول مسیریابی پیشوند منطقه خواهد بود. GK های راه دور باید فقط پیشوندهای منطقه محلی خود و یک مسیر پیش فرض علامت (*) به DGK را پیکربندی کنند.

با افزودن DGK، یک ساختار سلسله مراتبی با DGK به عنوان جزء بالاترین سطح ایجاد کرده ایم. ما هنوز می‌توانیم به اتصال کامل دست یابیم، اما با حداقل تعداد ورودی‌های منطقه راه دور در هر یک از GKها. بخش عمده ای از پیکربندی منطقه راه دور در DGK انجام می شود.

یک شبکه ارائه دهنده خدمات بزرگ باید به مناطق مختلف تقسیم شود تا از مسائل مقیاس پذیری با عملکرد و مدیریت پشتیبانی کند. هر GK منطقه ای مسئول حفظ ثبت GW در منطقه خود علاوه بر تصمیم گیری نهایی مسیریابی برای GW های پایان دهنده و مبدا است. DGKها مسئول ارتباطات بین منطقه ای در سراسر مناطق GK و انتخاب منطقه مناسب برای خاتمه تماس هستند.

در شکل 15، WesternGK از کد منطقه محلی 415 اطلاع دارد، و EasternGK مسئول کد منطقه 212 خود در منطقه محلی خود است. با استفاده از دستورات پیشوند zone، یک جدول مسیریابی به صورت ایستا بر روی هر GK پیکربندی می شود. برای کدهای منطقه محلی به آن GK خاص، GW واقعی را می توان برای مطابقت با کد منطقه محلی پیکربندی کرد. برای کدهای منطقه ای که از راه دور هستند (نه در آن GK)، از یک “مسیر ستاره” یا پیشوند منطقه (*) برای DGK استفاده کنید. اکنون DGK جدول پیشوند منطقه اصلی را حفظ خواهد کرد.

شکل 15 افزودن یک دروازه بان دایرکتوری

جدول پیشوند منطقه ایستا در هر یک از GK ها از شکل 14 ساده شده است. اکنون GKs و DGK ناحیه مانند پیکربندی زیر پیکربندی شده اند:

hostname WesternGK
!
gatekeeper
zone local WesternGK cisco.com 10.1.1.1
zone remote DGK cisco.com 10.4.1.1 1719
zone prefix WesternGK 415* gw-priority 10 SFGW
zone prefix DGK *
!
hostname CentralGK
!
gatekeeper
zone local CentralGK cisco.com 10.2.1.1
zone remote DGK cisco.com 10.4.1.1 1719
zone prefix CentralGK 312* gw-priority 10 ChicagoGW
zone prefix DGK *
!
hostname EasternGK
!
gatekeeper
zone local EasternGK cisco.com 10.3.1.1
zone remote DGK cisco.com 10.4.1.1 1719
zone prefix EasternGK 212* gw-priority 10 NYGW
zone prefix DGK *
!
hostname DGK
!
gatekeeper
zone local DGK cisco.com 10.4.1.1
zone remote WesternGK cisco.com 10.1.1.1 1719
zone remote CentralGK cisco.com 10.2.1.1 1719
zone remote EasternGK cisco.com 10.3.1.1 1719
zone prefix WesternGK 415*
zone prefix CentralGK 312*
zone prefix EasternGK 212*
lrq forward-queries

برای فعال کردن GK برای ارسال پیام‌های LRQ که حاوی آدرس‌های E.164 هستند که با پیشوندهای منطقه کنترل شده توسط GKهای راه دور مطابقت دارند، از دستور lrq فوروارد پرس و جو در حالت پیکربندی دروازه‌بان در پیکربندی‌های دروازه‌بان استفاده کنید.

عملکرد دروازه‌بان دایرکتوری
به طور متوسط، DGK به 25 درصد از CPU مورد نیاز GK های منطقه محلی نیاز دارد. بنابراین، اگر بار CPU در GK 40 درصد باشد، شما تنها به 10 درصد تخصیص CPU در DGK نیاز دارید. نرم افزار Cisco IOS دارای محدودیت پنج LRQ بازگشتی است. یک LRQ به پنج پرش محدود می شود. مناطق محلی و مناطق ارسال LRQ را می توان مخلوط کرد.

افزودن یک منطقه جدید و یک مثال مرکز نرخ جدید
فرض کنید شما یک ارائه دهنده خدمات هستید که برای کاربران در سانفرانسیسکو، شیکاگو و نیویورک حمل و نقل VoIP را فراهم می کند. کسب و کار در حال رشد است و شما می خواهید برنامه شماره گیری خود را طوری طراحی کنید که تغییرات زیر را در نظر بگیرد:

•یک منطقه جدید در منطقه زمانی کوهستان به کد منطقه خدمات 406 اضافه کنید.

• یک مرکز نرخ جدید در منطقه سانفرانسیسکو اضافه کنید.

سانفرانسیسکو مجموعه جدیدی از شماره های محلی را در کد منطقه 415 اضافه کرده است. با این حال، هزینه‌های عوارض در PSTN زمانی اعمال می‌شود که تماس‌گیرندگان با شماره‌های 415-626-xxxx با مشترکین با شماره‌های 415-961-xxxx تماس بگیرند. هنگام برقراری این تماس‌ها، استفاده از انتقال VoIP نسبت به PSTN برای کاربران هزینه کمتری دارد. شکل 16 اضافه شدن منطقه جدید و مرکز نرخ جدید را نشان می دهد.

شکل 16 افزودن یک مرکز نرخ و یک منطقه کوهستانی جدید به شبکه

در مثال پیکربندی زیر، یک منطقه جدید (منطقه کوهستانی) و یک مرکز نرخ جدید (سان فرانسیسکو) اضافه شده است:

hostname WesternGK
!
interface Ethernet0/0
ip address 172.19.49.168 255.255.255.192
!
gatekeeper
zone local WesternGK netman.com 172.19.49.168
zone remote DGK netman.com 172.19.49.190 1719
zone prefix WesternGK 1415626* gw-priority 10 SFGW
zone prefix WesternGK 1415961* gw-priority 10 SF2GW
zone prefix DGK *
gw-type-prefix 1#* default-technology
lrq forward-queries
no shutdown

DGK Configuration

gatekeeper
zone local DGK netman.com 172.19.49.190
zone remote WesternGK netman.com 172.19.49.168 1719
zone remote CentralGK netman.com 172.19.49.172 1719
zone remote EasternGK netman.com 172.19.49.176 1719
zone remote MountainGK netman.com 172.19.49.200 1719
zone prefix WesternGK 1415*
zone prefix CentralGK 1312*
zone prefix EasternGK 1212*
zone prefix MountainGK 1406*
lrq forward-queries
no shutdown

MountainGK Configuration

hostname MountainGK
!
interface Ethernet0/0
ip address 172.19.49.200 255.255.255.192
!
!
gatekeeper
zone local MountainGK netman.com 172.19.49.168
zone remote DGK netman.com 172.19.49.190 1719
zone prefix MountainGK 1496* gw-priority 10 MTGW
zone prefix DGK *
gw-type-prefix 1#* default-technology
lrq forward-queries
no shutdown

استفاده از قوانین ترجمه، پیشوندهای فناوری، و مثال شکست همتای شماره گیری
این مثال استفاده از ابزارها و ویژگی‌های Cisco IOS را برای ارائه کنترل بهتر مسیریابی تماس با طراحی سلسله مراتبی و به حداقل رساندن پیکربندی همتای شماره‌گیر نشان می‌دهد. شکل 17 توپولوژی شبکه نمونه را نشان می دهد.

شکل 17 مثال شبکه با استفاده از سناریوهای Failover

مورد تجاری
در این مثال، ارائه‌دهنده خدمات دو GW دارد که هر دو منطقه 408555* و 408777* NPA-NXX را ارائه می‌کنند. GK دارای دو منطقه محلی، گرگ و میش و hopoff است.

تماس از GWA به GWB باید از طریق شبکه VoIP دروازه‌بان انجام شود. با این حال، اگر GWB به دلیل خرابی یا مشکل تخصیص منابع در دسترس نیست، باید موارد زیر را رعایت کنید:

•تماس با شماره 408555* باید از طریق PSTN (GWA POTS) برگشته و به مقصد تکمیل شود. این تماس‌ها از طریق PSTN هیچ هزینه‌ای در داخل LATA ندارند.

•تماس با 408777* باید از طریق منطقه hopoff ارسال شود، نه به PSTN. هزینه عوارض داخل LATA در ارتباط با این تماس ها وجود دارد، بنابراین مشتری می خواهد این تماس ها را به منطقه هاپوف هدایت کند که نرخ بهتری دارد.

Cisco IOS Tools
در این مثال از ابزارهای زیر استفاده شده است:

•قوانین ترجمه: از قوانین ترجمه برای حذف یا اضافه کردن 1 به شماره تماس استفاده کنید تا امکان کنترل مسیریابی تماس اضافی در ترتیب انتخاب GW فراهم شود.

• فرمان ترجیحی: از فرمان ترجیحی در همتاهای شماره گیری استفاده کنید تا ترتیب انتخاب همتای شماره گیری را مجاز کنید. به عنوان مثال، دروازه ابتدا با شماره گیری شماره 1 مطابقت خواهد داشت. اگر GW یک پیام رد مکان (LRJ) از GK دریافت کند، شماره گیری ترجیحی بعدی استفاده خواهد شد. استفاده از دستور preference امکان سناریوهای Failover و کنترل بیشتر تماس را فراهم می کند.

•پیوندهای فناوری: از پیشوندهای فناوری استفاده کنید تا به همتایان شماره گیری خاصی اجازه دهید از پیشوند فناوری ناحیه هپوف (یعنی 27#) استفاده کنند. هنگامی که خطای همتای شماره گیری رخ می دهد، پیشوند فناوری 27#، تماس را مجبور می کند تا به منطقه hopoff برود.

•Hopoff zone: یک ناحیه hopoff و یک hopoff GW در شبکه ایجاد کنید. این منطقه دارای نرخ توافقی ویژه ای برای تماس های VoIP است، بنابراین هزینه تماس ها کمتر از تماس هایی است که از طریق PSTN انجام می شود.

تنظیمات نمونه
پیکربندی‌های زیر استفاده از قوانین ترجمه، پیشوندهای فناوری و خطای همتای شماره‌گیری را نشان می‌دهند:

GWA Configuration

hostname GWA
!
translation-rule 1
Rule 0 ^2.% 12
Rule 1 ^3.% 13
Rule 2 ^4.% 14
Rule 3 ^5.% 15
Rule 4 ^6.% 16
Rule 5 ^7.% 17
Rule 6 ^8.% 18
Rule 7 ^9.% 19
!
translation-rule 2
Rule 0 ^12.% 2
Rule 1 ^13.% 3
Rule 2 ^14.% 4
Rule 3 ^15.% 5
Rule 4 ^16.% 6
Rule 5 ^17.% 7
Rule 6 ^18.% 8
Rule 7 ^19.% 9
!
interface loopback0
h323-gateway voip interface
h323-gateway voip id GK ipaddr 172.20.10.9 1719
h323-gateway voip h323-id GWA
h323-gateway voip tech-prefix 1#
!
voice-port 0:D
translate called 1
no modem passthrough
!
dial-peer voice 2 voip
preference 5
destination-pattern 1408…….
session target ras
tech-prefix 27#
!
dial-peer voice 100 pots
destination-pattern …….
direct-inward-dial
port 0:D
prefix 1408
!
dial-peer voice 1 voip
preference 1
destination-pattern 1408…….
translate-outgoing called 2
session target ras

GWB Configuration

hostname GWB
!
interface loopback0
h323-gateway voip interface
h323-gateway voip id GK ipaddr 172.20.10.9 1719
h323-gateway voip h323-id GWB
h323-gateway voip tech-prefix 1#

Hopoff GW Configuration

hostname hopoff-gw
!
interface loopback0
h323-gateway voip interface
h323-gateway voip id GK ipaddr 172.20.10.9 1719
h323-gateway voip h323-id hopoff-gw

GK Configuration

hostname GK
!
gatekeeper
zone local twilight-zone cisco.com 172.20.10.10
zone local hopoff-zone cisco.com
zone prefix twilight-zone 408555* gw-priority 10 GWB
zone prefix twilight-zone 408555* gw-priority 5 GWA
zone prefix twilight-zone 408777* gw-priority 10 GWB
zone prefix twilight-zone 408777* gw-priority 0 GWA
zone prefix hopoff-zone 1408777* gw-priority 10 hopoff-gw
gw-type-prefix 1#* default-technology
gw-type-prefix 27#* hopoff hopoff-zone
no shutdown


GK# show gatekeeper gw-type-prefix

GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 1#* (Default gateway-technology)
Zone twilight-zone master gateway list:
172.20.10.3:1720 GWA
172.20.10.5:1720 GWB
Zone twilight-zone prefix 408777* priority gateway list(s):
Priority 10:
172.20.10.5:1720 GWB
Zone twilight-zone prefix 408555* priority gateway list(s):
Priority 10:
172.20.10.5:1720 GWB
Priority 5:
172.20.10.3:1720 GWA

Prefix: 27#* (Hopoff zone hopoff-zone)
Zone hopoff-zone master gateway list:
172.20.10.4:1720 hopoff-gw
Zone hopoff-zone prefix 1408777* priority gateway list(s):
Priority 10:
172.20.10.4:1720 hopoff-gw

بررسی پیکربندی و منطق طرح شماره گیری

این بخش جریان های زیر را نشان می دهد:

Configuration Review and Dial Plan Logic
This section shows the following flows:

•GWA calls 1408555* on GWB—Success

•GWA calls 1408555* on GWB—Failover through zone prefixes

•GWA calls 1408777* on GWB—Success

•GWA calls 1408777* on GWB—Failover using dial peer failover (preference command)

Flow 1: Success
GWA calls 1408555* on GWB:

1. Voice-port translation rule 1 adds 1 to the NPA.

2. Match dial peer 1 translation rule 2, which strips the digit 1. Send an ARQ message to the GK.

3. Match zone prefix twilight-zone 408555* gw-priority 10 GWB.

The call is successful through VoIP.

Flow 2: Failover Through Zone Prefixes
GWA calls 1408555* on GWB:

1. Voice-port translation rule 1 adds 1 to the NPA.

2. Match dial peer 1 translation rule 2, which strips the digit 1. Send an ARQ message to the GK.

3. Match zone prefix twilight-zone 408555* gw-priority 10 GWB.

4. GWB is down (or RAI unavailable), so GWB is removed from the GK selection table. Look for the next match.

5. Match zone prefix twilight-zone 408555* gw-priority 5 GWA.

6. Select GWA (itself).

7. Match on POTS dial peer, and destination pattern …….

8. Hairpin the call back through the PSTN.

The call is successful through the PSTN.

Flow 3: Success
GWA calls 1408777* on GWB:

1. Voice-port translation rule 1 adds 1 to the NPA.

2. Match dial peer 1 translation rule 2, which strips the digit 1. Send an ARQ message to the GK.

3. Match zone prefix twilight-zone 408777* gw-priority 10 GWB.

The call is successful through VoIP.

Flow 4: Failover Using Dial Peer Failover (preference Command)
GWA calls 1408777* on GWB:

1. Voice-port translation rule 1 adds 1 to the NPA.

2. Match dial peer 1 translation rule 2, which strips the digit 1. Send an ARQ message to the GK.

3. Match zone prefix twilight-zone 408777* gw-priority 10 GWB.

4. GWB is down (or RAI unavailable), so GWB is removed from the GK selection table. Look for the next match.

5. Match, but zone prefix twilight-zone 408777* gw-priority 0 GWA.

6. The GK sends an ARJ message to GWA.

7. Roll over to next preferred dial peer, dial peer 2.

8. Dial peer 2 does not strip the 1 (no translation rule) but does add a technology prefix of 27#, resulting in the number 27#14087771000.

9. GWA sends an ARQ message to the GK.

10. Match the gw-type-prefix 27#* hopoff hopoff-zone.

11. Match the zone prefix hopoff-zone 1408777* gw-priority 10 hopoff-gw.

12. In an ACF message, the GK sends the hopoff-gw address to GWA.

The call is successful to the hopoff GW.

اجرای نمونه طرح شماره گیری بین المللی
این پیاده‌سازی نمونه‌ای از یک طرح شماره‌گیری بین‌المللی را با استفاده از چندین روش تحت پوشش برای کاهش پیکربندی همتای شماره‌گیری در GW، ساده کردن جستجوهای پیشوند در GK، و ارائه تحمل خطا در سطح GK و DGK ارائه می‌کند. شکل 18 توپولوژی شبکه نمونه را نشان می دهد.

شکل 18 توپولوژی یک شبکه ارائه دهنده خدمات بین المللی

ارائه دهنده خدمات می خواهد خدمات صوتی عمده فروشی را با حضور در آمریکای شمالی، آسیا و EMEA ارائه دهد. باید یک Gateway، gatekeeper و Directory gatekeeper شبکه H.323 طراحی و پیکربندی کنید که مکان‌های POP زیر را فراهم کند:

  • آمریکای شمالی – GW در ایالات متحده است
  • آسیا—GW در چین است
  • EMEA—GW در فرانسه است

اهداف طراحی شبکه به شرح زیر است:

  • تماس های بین حامل های موفق بین کشورها
  • طراحی سلسله مراتبی GW، GK، DGK
  • عادی سازی شماره به VoIP از PSTN
  • تحمل خطا در سطح GK و DGK

شکل 19 یک نمونه توپولوژی را با این اهداف طراحی نشان می دهد.

شکل 19 توپولوژی شبکه با اطلاعات تماس خاص کشور

برای دستیابی به اهداف طراحی شبکه، استراتژی های طراحی شرح داده شده در بخش های زیر را اجرا کنید:

• عادی سازی شماره برای کاهش تعداد همتاهای شماره گیری در دروازه

• دایرکتوری دروازه بان و پیشوند منطقه محلی جستجو

• دروازه بان های جایگزین و جفت های HSRP برای تحمل خطا

عادی سازی شماره برای کاهش تعداد همتاهای شماره گیری در دروازه
برای کاهش تعداد همتاهای شماره گیری GW، قوانین ترجمه را روی هر GW ایجاد کنید تا با عادات شماره گیری محلی کشور مطابقت داشته باشد.

دروازه های ایالات متحده
راه اندازی شامل عناصر زیر است:

•دو GW در POP ایالات متحده واقع شده است.

•US-GW1 دارای شماره تلفن 14085271000 است.

•US-GW2 دارای شماره تلفن 14087791000 است.

عادات شماره گیری محلی در ایالات متحده به شرح زیر است:

•برای شماره های محلی در کد منطقه 408، از شماره گیری 7 رقمی استفاده کنید.

• برای شماره های راه دور در ایالات متحده، از 1 + کد منطقه + شماره محلی استفاده کنید.

•برای شماره های بین المللی (خارج از آمریکای شمالی)، از 011 (کد دسترسی) + کد کشور + کد شهر محلی + شماره محلی استفاده کنید.

این اعداد را به فرمول زیر عادی کنید:

کد کشور + کد شهر + شماره محلی

دروازه چین
تنظیمات برای چین به شرح زیر است:

• One GW در POP چین قرار دارد.

•کد کشور = 86، کد شهر محلی = 010.

•CHINA-GW1 دارای تلفن 861011112222 است.

عادات شماره گیری محلی در چین به شرح زیر است:

•برای شماره های محلی در کد شهر 010، از شماره گیری 8 رقمی استفاده کنید که با اعداد 1 تا 9 شروع می شود.

• برای شماره های راه دور در چین، از کد منطقه (با 0x یا 0xx شماره گیری شده) + شماره محلی استفاده کنید.

•برای شماره های بین المللی (خارج از چین)، از 00 (کد دسترسی) + کد کشور + کد شهر محلی + شماره محلی استفاده کنید.

این اعداد را به فرمول زیر عادی کنید:

کد کشور + کد شهر + شماره محلی

دروازه فرانسه
تنظیمات برای فرانسه به شرح زیر است:

• One GW در POP فرانسه قرار دارد.

•کد کشور = 33، کد شهر محلی = 03.

•FRANCE-GW1 دارای تلفن 330311112222 است.

عادات شماره گیری محلی در فرانسه به شرح زیر است:

•برای شماره های محلی در کد منطقه 03، از کد منطقه (0x) + شماره گیری 8 رقمی استفاده کنید.

• برای شماره های مسافت طولانی در فرانسه، از کد منطقه (با 0x شماره گیری شده) + شماره محلی 8 رقمی استفاده کنید.

•برای شماره های بین المللی (خارج از فرانسه)، از 00 (کد دسترسی) + کد کشور + کد شهر محلی + شماره محلی استفاده کنید.

این اعداد را به فرمول زیر عادی کنید:

کد کشور + کد شهر + شماره محلی

قوانین ترجمه باید به گونه ای پیکربندی شوند که با عادات شماره گیری محلی در کشوری که GW در آن ساکن است مطابقت داشته باشد. قانون ترجمه را با شماره گیری VoIP خروجی مناسب مطابقت دهید.

جستجوی پیشوند دروازه‌بان دایرکتوری و منطقه محلی
دروازه بان ها به گونه ای پیکربندی شده اند که مناطق کشور محلی و کدهای شهر یا منطقه خود را (به عنوان مثال، 8610*) به GW های خاص خود مدیریت کنند. یک DGK برای رسیدگی به مسیریابی تماس فقط در شماره کد کشور استفاده می شود. این عملکرد سلسله مراتبی ممکن است زیرا GK قوانین ترجمه را برای ارائه این کد کشور ابتدا قبل از ورود به هسته دروازه‌بان VoIP اعمال می‌کند. علاوه بر این، جداول پیشوند زون در GK های ناحیه بسیار ساده شده است زیرا DGK در آن طراحی شده است.

دروازه‌بان‌های جایگزین و جفت‌های HSRP برای تحمل خطا
دروازه بان های جایگزین در سطح منطقه GK برای پشتیبان گیری از GK های اولیه پیکربندی شده اند. یک جفت HSRP اولیه و ثانویه در سطح DGK برای پشتیبان گیری از یکدیگر استفاده می شود. یک DGK ثانویه برای پشتیبان گیری از جفت DGK استفاده می شود.

توجه داشته باشید تنظیمات مربوط به GK جایگزین در POP ایالات متحده نشان داده شده است. تنظیمات برای GK جایگزین در آسیا و فرانسه POP نشان داده نشده است.

لیست های پیکربندی
پیکربندی های زیر برای اجرای طرح شماره گیری بین المللی آمده است:

US-GW1 Configuration

Current configuration:
!
! No configuration change since last restart
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname US-GW1
!
enable password xxx
!
username cisco password 0 xxx
!
clock timezone PDT -7
ip subnet-zero
no ip domain-lookup
!
translation-rule 2
Rule 0 ^2…… 14082
Rule 1 ^3…… 14083
Rule 2 ^4…… 14084
Rule 3 ^5…… 14085
Rule 4 ^6…… 14086
Rule 5 ^7…… 14087
Rule 6 ^8…… 14088
Rule 7 ^9…… 14089
!
translation-rule 1
Rule 0 ^0111.% 1
Rule 1 ^0112.% 2
Rule 2 ^0113.% 3
Rule 3 ^0114.% 4
Rule 4 ^0115.% 5
Rule 5 ^0116.% 6
Rule 6 ^0117.% 7
Rule 7 ^0118.% 8
Rule 8 ^0119.% 9
!
interface Ethernet0/0
ip address 172.19.49.166 255.255.255.192
h323-gateway voip interface
h323-gateway voip id NA-GK ipaddr 172.19.49.168 1719 priority 1
h323-gateway voip id NA-ALTGK ipaddr 172.19.49.169 1719 priority 2
h323-gateway voip h323-id US-GW1
h323-gateway voip tech-prefix 1#
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.49.129
no ip http server
!
voice-port 1/0/0
timeouts interdigit 3
!
voice-port 1/0/1
!
dial-peer cor custom
!
dial-peer voice 1408 pots
destination-pattern 14085271000
port 1/0/0
!
dial-peer voice 1 voip
destination-pattern 011T
translate-outgoing called 1
session target ras
!
dial-peer voice 4 voip
destination-pattern [2-9]……
translate-outgoing called 2
session target ras
!
dial-peer voice 99 voip
destination-pattern 2601
session target ipv4:172.19.49.4
!
dial-peer voice 2 voip
destination-pattern 1T
session target ras
!
gateway
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password xxx
!
end
US-GW2 Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname US-GW2
!
enable password xxx
!
username cisco password 0 xxx
!
ip subnet-zero
no ip domain-lookup
!
call rsvp-sync
!
translation-rule 1
Rule 0 ^0111.% 1
Rule 1 ^0112.% 2
Rule 2 ^0113.% 3
Rule 3 ^0114.% 4
Rule 4 ^0115.% 5
Rule 5 ^0116.% 6
Rule 6 ^0117.% 7
Rule 7 ^0118.% 8
Rule 8 ^0119.% 9
!
translation-rule 4
Rule 0 ^2…… 14082
Rule 1 ^3…… 14083
Rule 2 ^4…… 14084
Rule 3 ^5…… 14085
Rule 4 ^6…… 14086
Rule 5 ^7…… 14087
Rule 6 ^8…… 14088
Rule 7 ^9…… 14089
!
interface Ethernet0/0
ip address 172.19.49.167 255.255.255.192
h323-gateway voip interface
h323-gateway voip id NA-GK ipaddr 172.19.49.168 1719 priority 1
h323-gateway voip id NA-ALTGK ipaddr 172.19.49.169 1719 priority 2
h323-gateway voip h323-id US-GW2
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.49.129
no ip http server
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer cor custom
!
dial-peer voice 1 voip
destination-pattern 011T
translate-outgoing called 1
session target ras
!
dial-peer voice 2 voip
destination-pattern 1T
session target ras
!
dial-peer voice 1408 pots
destination-pattern 14087791000
port 1/0/0
!
dial-peer voice 4 voip
destination-pattern [2-9]……
translate-outgoing called 4
session target ras
!
gateway
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password xxx
!
end
China-GW1 Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CHINA-GW1
!
username cisco password 0 xxx
!
ip subnet-zero
no ip domain-lookup
!
translation-rule 2
Rule 0 ^01.% 8601
Rule 1 ^02.% 8602
Rule 2 ^03.% 8603
Rule 3 ^04.% 8604
Rule 4 ^05.% 8605
Rule 5 ^06.% 8606
Rule 6 ^07.% 8607
Rule 7 ^08.% 8608
Rule 8 ^09.% 8609
!
translation-rule 1
Rule 0 ^001.% 1
Rule 1 ^002.% 2
Rule 2 ^003.% 3
Rule 3 ^004.% 4
Rule 4 ^005.% 5
Rule 5 ^006.% 6
Rule 6 ^007.% 7
Rule 7 ^008.% 8
Rule 8 ^009.% 9
!
interface Ethernet0/0
ip address 172.19.49.170 255.255.255.192
h323-gateway voip interface
h323-gateway voip id AS-GK ipaddr 172.19.49.172 1719
h323-gateway voip h323-id CHINA-GW1
h323-gateway voip tech-prefix 1#
!
interface Ethernet0/1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.49.129
no ip http server
!
voice-port 1/0/0
timeouts interdigit 3
!
voice-port 1/0/1
!
dial-peer cor custom
!
dial-peer voice 1 voip
destination-pattern 00T
translate-outgoing called 1
session target ras
!
dial-peer voice 2 voip
destination-pattern 86T
session target ras
!
dial-peer voice 3 voip
destination-pattern 0[1-9]T
translate-outgoing called 2
session target ras
!
dial-peer voice 8610 pots
destination-pattern 861011112222
port 1/0/0
!
gateway
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password xxx
!
end
France-GW1 Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FRANCE-GW1
!
no logging console
enable password xxx
!
username cisco password 0 xxx
!
ip subnet-zero
no ip domain-lookup
!
call rsvp-sync
!
dial-control-mib retain-timer 60
dial-control-mib max-size 1200
!
translation-rule 2
Rule 0 ^01.% 3301
Rule 1 ^02.% 3302
Rule 2 ^03.% 3303
Rule 3 ^04.% 3304
Rule 4 ^05.% 3305
Rule 5 ^06.% 3306
!
translation-rule 1
Rule 0 ^0011.% 1
Rule 1 ^0012.% 2
Rule 2 ^0013.% 3
Rule 3 ^0014.% 4
Rule 4 ^0015.% 5
Rule 5 ^0016.% 6
Rule 6 ^0017.% 7
Rule 7 ^0018.% 8
Rule 8 ^0019.% 9
!
translation-rule 3
Rule 0 ^001.% 1
Rule 1 ^002.% 2
Rule 2 ^003.% 3
Rule 3 ^004.% 4
Rule 4 ^005.% 5
Rule 5 ^006.% 6
Rule 6 ^007.% 7
Rule 7 ^008.% 8
Rule 8 ^009.% 9
!
interface Ethernet0/0
ip address 172.19.49.174 255.255.255.192
h323-gateway voip interface
h323-gateway voip id E-GK ipaddr 172.19.49.176 1719
h323-gateway voip h323-id FRANCE-GW1
h323-gateway voip tech-prefix 1#
!
interface Ethernet0/1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.49.129
no ip http server
!
voice-port 1/0/0
timeouts interdigit 3
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
dial-peer voice 3301 pots
destination-pattern 330311112222
port 1/0/0
!
dial-peer voice 1 voip
destination-pattern 00T
translate-outgoing called 3
session target ras
!
dial-peer voice 2 voip
destination-pattern 0[1-6]……..
translate-outgoing called 2
session target ras
!
gateway
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password xxx
login local
!
no scheduler allocate
end
NA-GK (North America Gatekeeper) Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NA-GK
!
no logging console
enable password xxx
!
username cisco password 0 xxx
!
ip subnet-zero
no ip domain-lookup
!
dial-control-mib retain-timer 60
dial-control-mib max-size 1200
!
interface Ethernet0/0
ip address 172.19.49.168 255.255.255.192
!
interface Ethernet0/1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.49.129
no ip http server
!
snmp-server engineID local 0000000902000001969C63E0
snmp-server community public RW
snmp-server packetsize 4096
!
dial-peer cor custom
!
gatekeeper
zone local NA-GK netman.com 172.19.49.168
zone remote NA-ALTGK netman.com 172.19.49.169 1719
zone remote DGK netman.com 172.19.49.190 1719
zone remote ALTDGK netman.com 172.19.49.180 1719
zone prefix NA-GK 1408527* gw-priority 10 US-GW1
zone prefix NA-GK 1408779* gw-priority 10 US-GW2
zone prefix NA-GK 1408*
zone prefix NA-ALTGK 1408*
zone prefix DGK *
zone prefix ALTDGK *
gw-type-prefix 1#* default-technology
lrq forward-queries
no shutdown
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password xxx
login local
!
no scheduler allocate
end
NA-AltGK (North America Alternate Gatekeeper) Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NA-ALTGK
!
enable password xxx
!
ip subnet-zero
!
interface Ethernet0/0
ip address 172.19.49.169 255.255.255.0
!
interface Ethernet0/1
no ip address
shutdown
!
ip classless
no ip http server
!
dial-peer cor custom
!
gatekeeper
zone local NA-ALTGK netman.com 172.19.49.169
zone remote NA-GK netman.com 172.19.49.168 1719
zone remote DGK netman.com 172.19.49.190 1719
zone remote ALTDGK netman 172.19.49.180 1719
zone prefix NA-ALTGK 1408527* gw-priority 10 US-GW1
zone prefix NA-ALTGK 1408779* gw-priority 10 US-GW2
zone prefix NA-GK 1408*
zone prefix DGK *
zone prefix ALTDGK *
gw-type-prefix 1#* default-technology
lrq forward-queries
no shutdown
!
line con 0
transport input none
line aux 0
line vty 0 4
password xxx
login
!
end
AS-GK (Asia Gatekeeper) Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS-GK
!
no logging console
enable password xxx
!
username cisco password 0 xxx
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0/0
ip address 172.19.49.172 255.255.255.192
!
interface Ethernet0/1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.49.129
no ip http server
!
snmp-server engineID local 0000000902000001969C63A0
snmp-server community public RW
!
dial-peer cor custom
!
gatekeeper
zone local AS-GK netman.com 172.19.49.172
zone remote DGK netman.com 172.19.49.190 1719
zone remote ALTDGK netman.com 172.19.49.184 1719
zone prefix AS-GK 8610* gw-priority 10 CHINA-GW1
zone prefix DGK *
zone prefix ALTDGK *
no shutdown
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password xxx
login local
!
no scheduler allocate
end
E-GK (EMEA Gatekeeper) Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname E-GK
!
no logging console
enable password xxx
!
username cisco password 0 xxx
!
clock timezone PDT -7
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0/0
ip address 172.19.49.176 255.255.255.192
!
interface Ethernet0/1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.49.129
no ip http server
!
snmp-server engineID local 00000009020000024B8FEF60
snmp-server community public RW
!
dial-peer cor custom
!
gatekeeper
zone local E-GK netman.com 172.19.49.176
zone remote DGK netman.com 172.19.49.190 1719
zone remote ALTDGK netman.com 172.19.49.180 1719
zone prefix E-GK 3303* gw-priority 10 FRANCE-GW1
zone prefix DGK *
zone prefix ALTDGK *
no shutdown
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password xxx
login local
!
ntp clock-period 17207746
ntp server 172.19.49.166
no scheduler allocate
end
DGK (Directory Gatekeeper—Primary HSRP) Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DGK
!
enable password xxx
!
ip subnet-zero
!
interface FastEthernet0/0
ip address 172.19.49.178 255.255.255.192
duplex auto
speed auto
standby 1 priority 110
standby 1 ip 172.19.49.190
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
no ip classless
ip route 0.0.0.0 0.0.0.0 172.19.49.129
no ip http server
!
dial-peer cor custom
!
gatekeeper
zone local DGK netman.com 172.19.49.190
zone remote NA-GK netman.com 172.19.49.168 1719
zone remote AS-GK netman.com 172.19.49.172 1719
zone remote E-GK netman.com 172.19.49.176 1719
zone remote NA-AGK netman.com 172.19.49.169 1719
zone prefix NA-GK 1*
zone prefix E-GK 33*
zone prefix AS-GK 86*
lrq forward-queries
no shutdown
!
line con 0
transport input none
line aux 0
line vty 0 4
password xxx
login
DGK2 (Directory Gatekeeper—Secondary HSRP) Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DGK2
!
boot system flash c3640-ix-mz.121-2.T.bin
enable password xxx
!
ip subnet-zero
!
interface FastEthernet0/0
ip address 172.19.49.179 255.255.255.192
no ip redirects
duplex auto
speed auto
standby 1 ip 172.19.49.190
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
no ip classless
no ip http server
!
gatekeeper
zone local DGK netman.com 172.19.49.190
zone remote NA-GK netman.com 172.19.49.168 1719
zone remote AS-GK netman.com 172.19.49.172 1719
zone remote E-GK netman.com 172.19.49.176 1719
zone remote NA-AGK netman.com 172.19.49.169 1719
zone prefix NA-GK 1*
zone prefix E-GK 33*
zone prefix AS-GK 86*
lrq forward-queries
no shutdown
!
line con 0
transport input none
line aux 0
line vty 0 4
password xxx
login
!
end
ALT-DGK (Secondary Directory Gatekeeper) Configuration

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ALT-DGK
!
boot system flash c3640-ix-mz.121-2.T.bin
enable password xxx
!
ip subnet-zero
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.19.49.184 255.255.255.192
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
no ip classless
no ip http server
!
gatekeeper
zone local DGK netman.com 172.19.49.190
zone remote NA-GK netman.com 172.19.49.168 1719
zone remote AS-GK netman.com 172.19.49.172 1719
zone remote E-GK netman.com 172.19.49.176 1719
zone remote NA-AGK netman.com 172.19.49.169 1719
zone prefix NA-GK 1*
zone prefix E-GK 33*
zone prefix AS-GK 86*
lrq forward-queries
no shutdown
!
line con 0
transport input none
line aux 0
line vty 0 4
password xxx
login
!
end